summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 07:48:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 08:08:37 +0100
commit91b1da2357841da819817888a33133c1818e89ef (patch)
treeced9416f2bbb9f58e395cad6a4988b0164192fbc
parentdev-python/mkdocs-material: Bump to 9.0.9 (diff)
downloadgentoo-91b1da2357841da819817888a33133c1818e89ef.tar.gz
gentoo-91b1da2357841da819817888a33133c1818e89ef.tar.bz2
gentoo-91b1da2357841da819817888a33133c1818e89ef.zip
dev-python/pyproject-metadata: Bump to 0.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyproject-metadata/Manifest1
-rw-r--r--dev-python/pyproject-metadata/pyproject-metadata-0.7.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyproject-metadata/Manifest b/dev-python/pyproject-metadata/Manifest
index 987f905de4c9..95d895807b01 100644
--- a/dev-python/pyproject-metadata/Manifest
+++ b/dev-python/pyproject-metadata/Manifest
@@ -1,2 +1,3 @@
DIST pyproject-metadata-0.5.0.gh.tar.gz 13816 BLAKE2B 8f5613c1279539116e99b6f319b687a08160360109e1ed71d5bc6c0434ee316ef7c0b7109d6769a03452a41c1b258765c849fe416b4632b4ba25990b6b3702aa SHA512 66cd447a01d0d01ab37611415bd620517600af667d7179a2696f763ae031c013393c8145ebd33f27b43629659333effa58596a02dfc5c217935c90475250b822
DIST pyproject-metadata-0.6.1.gh.tar.gz 14047 BLAKE2B d97be3532450541f4f464eca8d3e241259463bbd9d8277df380e3bf38908b9fd4e279d4ec88051e974a51091da9afef0691c7d723213e244c9fb5a6b6fa1e7ac SHA512 4af84f9534a5c71e192e1355e1e99f99e82b97d01411c011ed2f1dff579a7420a0f5d982eea5a032de8549c14191b64334c8e2aeea22fe767837e662e8d8b588
+DIST pyproject-metadata-0.7.1.gh.tar.gz 14138 BLAKE2B 901e0b0b07d035ee220cfdba840a2b05ec1b1dfa3184ab614621c462b049bdbe484aa2d9abc42a54964c163d360028a00ff1db2c502504d11fb6d2837bd60552 SHA512 a4cb97b6646b765016f047f8d3da388ab758dbf8acf5a8ee6ccb017c764a90c069e04effbef21f878be7f4b01a5090f24252372300ce7e3a0410a6eea5d98b66
diff --git a/dev-python/pyproject-metadata/pyproject-metadata-0.7.1.ebuild b/dev-python/pyproject-metadata/pyproject-metadata-0.7.1.ebuild
new file mode 100644
index 000000000000..d5e0c16768f2
--- /dev/null
+++ b/dev-python/pyproject-metadata/pyproject-metadata-0.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="PEP 621 metadata parsing"
+HOMEPAGE="
+ https://github.com/FFY00/python-pyproject-metadata/
+ https://pypi.org/project/pyproject-metadata/
+"
+SRC_URI="
+ https://github.com/FFY00/python-pyproject-metadata/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/python-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+ )
+"
+
+distutils_enable_tests pytest