summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-04 17:06:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-04 18:34:04 +0200
commit91bd1ac96387cbd0e738a5673e7b665e4df5d518 (patch)
treec3cbf50f7c8e6f7a5c74d1ed217dcbbd2efd9460
parentmedia-libs/libsamplerate: Fix file collision with media-sound/sndfile-tools (diff)
downloadgentoo-91bd1ac96387cbd0e738a5673e7b665e4df5d518.tar.gz
gentoo-91bd1ac96387cbd0e738a5673e7b665e4df5d518.tar.bz2
gentoo-91bd1ac96387cbd0e738a5673e7b665e4df5d518.zip
media-sound/sndfile-tools: Tarball respun, EAPI-7 bump
Drop bogus slot ops. Block colliding media-libs/libsamplerate versions. Closes: https://bugs.gentoo.org/645256 Closes: https://bugs.gentoo.org/736459 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/sndfile-tools/Manifest1
-rw-r--r--media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild40
-rw-r--r--media-sound/sndfile-tools/sndfile-tools-9999.ebuild24
3 files changed, 54 insertions, 11 deletions
diff --git a/media-sound/sndfile-tools/Manifest b/media-sound/sndfile-tools/Manifest
index 98479ed7d612..eea453ac6255 100644
--- a/media-sound/sndfile-tools/Manifest
+++ b/media-sound/sndfile-tools/Manifest
@@ -1,2 +1,3 @@
DIST sndfile-tools-1.03.tar.gz 474494 BLAKE2B 17c8f6782895a5e02bcd39e0e966a9196fe26b8fa192b3375a4f167cb554de168d4ce4e638d792720ee3e74483a88060ef9bf6d3713c91834acc9b39427185e2 SHA512 bc6ac7977a95ccf845c889db81452ae84b4f10a8f51c91ddd6fe4d926337a60cdbcb2859b0758816622554bf26a6e42b70f791f2c5158926c3f92ab2abbf14dc
DIST sndfile-tools-1.04.tar.bz2 714880 BLAKE2B 14d8f9a8172e4e3d8fe320baf3e546c3998636c0de36e8b41e38e277c18f2af6c3ea944eb4cecdda0e225fa3d7adbcd3a5618e74a9d567c42eb0056f162703e3 SHA512 90b0121f4d0bf3ebf3962cc47bcd6a11e5a644d0567be137a8bcf5881944e03e3c9650c9813c982a58072154f62dd176c46cfe83e5661ff81205db30923b71d3
+DIST sndfile-tools-1.04a.tar.bz2 715692 BLAKE2B e65a222bfdd96803293f006c2c5704fd1037d81524559d86c8e3812b91bd90fa0b47d1f589adb303f68e1ffdbebfd8b4ec616c9f1d897ad993768981c83022e3 SHA512 b93fd74386960c986031fd1652335bc34243bd785ccf31480b82f4d76ef86760ca53173aace273a635db70db46c0c1c4066328aef9c21c01c6e76346dbe56390
diff --git a/media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild b/media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild
new file mode 100644
index 000000000000..946196cd2f67
--- /dev/null
+++ b/media-sound/sndfile-tools/sndfile-tools-1.04-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small collection of programs that use libsndfile"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile/tools/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/erikd/sndfile-tools.git"
+else
+ SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.bz2 -> ${P}a.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="jack"
+
+DEPEND="
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ x11-libs/cairo
+ sci-libs/fftw:3.0=
+ jack? ( virtual/jack )
+"
+RDEPEND="${DEPEND}
+ !<media-libs/libsamplerate-0.1.9-r1
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable jack)
+}
diff --git a/media-sound/sndfile-tools/sndfile-tools-9999.ebuild b/media-sound/sndfile-tools/sndfile-tools-9999.ebuild
index 46defab32442..6ed4dd5751d3 100644
--- a/media-sound/sndfile-tools/sndfile-tools-9999.ebuild
+++ b/media-sound/sndfile-tools/sndfile-tools-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-DESCRIPTION="A small collection of programs that use libsndfile"
+DESCRIPTION="Small collection of programs that use libsndfile"
HOMEPAGE="http://www.mega-nerd.com/libsndfile/tools/"
if [[ ${PV} == *9999 ]]; then
@@ -18,15 +18,17 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="jack"
-RDEPEND="
- media-libs/libsndfile:=
- media-libs/libsamplerate:=
- x11-libs/cairo:=
- sci-libs/fftw:3.0=
- jack? ( media-sound/jack-audio-connection-kit:= )"
DEPEND="
- virtual/pkgconfig
- ${RDEPEND}"
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ x11-libs/cairo
+ sci-libs/fftw:3.0=
+ jack? ( virtual/jack )
+"
+RDEPEND="${DEPEND}
+ !<media-libs/libsamplerate-0.1.9-r1
+"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default