summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-30 07:53:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-30 09:06:44 +0100
commit91c1df6bfb4184701717164de27c770fe6f67b17 (patch)
treee96917b32e20b41a2a01a27708e34c609c0c5bd5
parentnet-print/cups: Stabilize 2.3.3_p2-r3 sparc, #827838 (diff)
downloadgentoo-91c1df6b.tar.gz
gentoo-91c1df6b.tar.bz2
gentoo-91c1df6b.zip
dev-python/pikepdf: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-4.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index ae37cbc821c7..5000f824925d 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -2,3 +2,4 @@ DIST pikepdf-3.2.0.tar.gz 2335339 BLAKE2B 3d294c2c8241bfcfa2b84f4c6af10e4da2e624
DIST pikepdf-4.0.0.tar.gz 2335830 BLAKE2B 80e36162709cd9eb23ce70994286d51cd4e83d242dafe65c724fa64a46b67bee048d76efa3934717334ba196d98d7ec70dd7f20b5d42a2a2d56326603f0adc88 SHA512 5727f60c05a72d1b7a249803020358cbb579e180ad1e5685d6120443b75a2b8483bd16c5c705f1fccd5159a0ab23a8b844ab57d39499ce4bf883e5caf2710051
DIST pikepdf-4.0.1.tar.gz 2335951 BLAKE2B 760e80991d902b37d2d1a832e5d0c2685603e409772cc3cbf5a2ec24230ff0b10989adc7ca78c7f335fc8214df537479b303bab35bd7754c8397ccb72ed56cf7 SHA512 b552f711324eb81fa6f848500ecc2ea215cb938464a4cc6d02348ef3feeda8fc1fbab9b96601b4f5ad1f950322b8d68ddb3ae5bf0b3a703fc07bdc973aa36afd
DIST pikepdf-4.0.2.tar.gz 2336204 BLAKE2B d7c8e0c16195b2738302ebc4d29f898a590716ddcf382776a8ea55c75bb39a491473f552bf51b1daad76e74999e2c006282f4b861ce0c8bc967bc4a94740af46 SHA512 a2f1df8d6ae427e59a03232bead0034ef27ff68123efdb522da6ceaeb0d213182b8f6cce11bf89f0c39b464a8569e40164e2b028e2fd6b8b166ab45bf89aff11
+DIST pikepdf-4.1.0.tar.gz 2336449 BLAKE2B 78f8fe63f1a6d95e08f2ffc079bd76d2416c1b67969d6267b1e9641d339d1a0699471440236dbe572449f813ffb8d659466db741f000354799df35b4189019df SHA512 da7fd1ab0a159e280eec858700af0cd13adf4b649149944499e344ef3c54297838297827f4a86ff59a156440d80b684791fa021c5d09340994da69820bdae260
diff --git a/dev-python/pikepdf/pikepdf-4.1.0.ebuild b/dev-python/pikepdf/pikepdf-4.1.0.ebuild
new file mode 100644
index 000000000000..80dd3fd26a41
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-4.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=app-text/qpdf-10.3.1:0="
+RDEPEND="${DEPEND}
+ >=dev-python/pillow-7[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.0[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.7.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/pybind11-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-4.1[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )"
+
+#distutils_enable_sphinx docs \
+# dev-python/ipython \
+# dev-python/matplotlib \
+# dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/-n auto/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}