summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-10-31 09:38:09 -0400
committerKenton Groombridge <concord@gentoo.org>2022-10-31 09:41:08 -0400
commit91c3d84a7e705be9a8976a8d0254b9a0f0f83ef7 (patch)
tree79e109cf2c4b8025127f238294936123db33b605
parentwww-apps/miniflux: add 2.0.39 (diff)
downloadgentoo-91c3d84a.tar.gz
gentoo-91c3d84a.tar.bz2
gentoo-91c3d84a.zip
www-apps/miniflux: drop 2.0.37
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
-rw-r--r--www-apps/miniflux/Manifest2
-rw-r--r--www-apps/miniflux/miniflux-2.0.37.ebuild98
2 files changed, 0 insertions, 100 deletions
diff --git a/www-apps/miniflux/Manifest b/www-apps/miniflux/Manifest
index dda3cc2225e7..c2edca5f3fa4 100644
--- a/www-apps/miniflux/Manifest
+++ b/www-apps/miniflux/Manifest
@@ -1,5 +1,3 @@
-DIST miniflux-2.0.37-deps.tar.xz 154048036 BLAKE2B 88eaba31505c4d1ace55428a8e29dac8449776e1f9cd9a9fe5a54f21dee65df8ddb9c8cfc88968ec4476cc5e3d7670f47ffc98d41ea5a6fe1ae9e23bb6b09807 SHA512 c499964a174a0cef1ec09824e8b6f9fbe3ff8eb77e2f5f9f4aedd73f95c569338afd4ec5c9c312556c9435863c8a4398b63a5f24a55c61d0d8a5afd63a83f31b
-DIST miniflux-2.0.37.tar.gz 555360 BLAKE2B 64188e03583dd011261c2d69c30e105af65d61ed996c4c2785621aa74d6b0602eaeed312750a089dfb1c4f5bc00c26f79549f2df27714cdca44506439b2ba6af SHA512 6944e638cdec6d0d5e92362ad4849028d0260780919eff8d6b6999327f9a482a1b3b09f1479b3c8c4b2727ced524caa13a6c7ac655b230ff244519cfe095cbd5
DIST miniflux-2.0.38-deps.tar.xz 154290660 BLAKE2B f8317e54ec3639e9bc90f9f28d4c645a816d8b8510df090145a87e9247c4762303276646505abf083d99dcf172a9a022c4771fdad58811779a47018158cd7690 SHA512 6390a6c06fb00428ff3088e81f9cca2b6343f77cc1151ccb8864eabac2983ec05630d18199b152c50fc7f463b14b7615fd901260444f00d4d6337740689d1eb3
DIST miniflux-2.0.38.tar.gz 568359 BLAKE2B 5e29663c59debdbdb4c0ed8da5d27e47ad0c0db70368844c3ede965050f0fa8410e6cd14e28faf811f39a39f0b5417d2b59302ac7cf00acfea977ab2b4b732ee SHA512 7ebedc469b8aa08e8ce73b8ae0e586927847f08e541e57fdc41b440a50524649938eb86ee56d885c688e83f1aa09063514eac4c1d8ad22459589b1ea994ef8ff
DIST miniflux-2.0.39-deps.tar.xz 149668196 BLAKE2B ded3bcf0ac706092570d41669cbdfef68d3aab764790f3a6fd09cf8fb436765f7c10abde9422a1aa70ce31d1e186558732f8208b8a77d1ce28dc212c5e855031 SHA512 cea27e014a8d88bbd77b018d9f02736b4f7c9d39c72fa2358b581e0a01be58b9ca132d414e3c562bdaaab8c89e08a938f7b0ef94821a8a76b1025f1d7ac2a63b
diff --git a/www-apps/miniflux/miniflux-2.0.37.ebuild b/www-apps/miniflux/miniflux-2.0.37.ebuild
deleted file mode 100644
index 005822d6132c..000000000000
--- a/www-apps/miniflux/miniflux-2.0.37.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module systemd
-
-DESCRIPTION="Minimalist and opinionated feed reader"
-HOMEPAGE="https://miniflux.app https://github.com/miniflux/v2"
-SRC_URI="https://github.com/${PN}/v2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="test" # requires network access
-
-DEPEND="acct-user/miniflux"
-RDEPEND="${DEPEND}
- >=dev-db/postgresql-9.5
-"
-
-S="${WORKDIR}/v2-${PV}"
-
-src_compile() {
- ego build -ldflags="-s -w -X 'miniflux.app/version.Version=${PV}' " -o miniflux main.go
-}
-
-src_install() {
- dobin miniflux
-
- insinto /etc
- doins "${FILESDIR}/${PN}.conf"
-
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
-
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- fowners miniflux:root /etc/${PN}.conf
- fperms o-rwx /etc/${PN}.conf
-
- local DOCS=(
- ChangeLog
- README.md
- "${FILESDIR}"/README.gentoo
- )
-
- # Makefile has no install target, so call einstalldocs directly
- einstalldocs
-
- doman "${PN}".1
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
-
- echo
- elog "Before using miniflux, you must first create and initialize the database"
- elog "and enable the hstore extension for it."
- elog ""
- elog "Afterwards, create your first admin user by running:"
- elog " miniflux -create-admin"
- else
- # This is an existing installation
-
- echo
- elog "If you are upgrading from a previous version, schema migrations must be performed."
- elog "To perform the migrations, stop the daemon, backup your database, and run:"
- elog " emerge --config =${PF}"
- fi
-
- echo
- elog "Please read"
- elog ""
- elog " ${EPREFIX}/usr/share/doc/${PF}/README.gentoo*"
- elog ""
- elog "for more information."
-}
-
-pkg_config() {
- # To be safe, avoid doing migrations if miniflux is running
- if pgrep miniflux; then
- die "miniflux appears to be running, refusing to continue."
- fi
-
- # Extract the database URL variable instead of just sourcing the config file
- # because miniflux itself may interpret quotes as part of the URL
- local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' ${EROOT}/etc/${PN}.conf)"
- [[ -n "${DATABASE_URL}" ]] || die "Failed getting DATABASE_URL from config file"
-
- DATABASE_URL="${DATABASE_URL}" "${EROOT}"/usr/bin/miniflux -migrate || die "miniflux -migrate failed. Please check the above output for errors."
-
- echo
- elog "Database migrations complete."
-}