summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-13 10:31:03 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-13 16:18:29 +0200
commit91f91926e801af9a19969127534b0feeb4fdacdd (patch)
treea87ec1ab11f1bc9069da2f4ae478bf4a876efe8f
parentsys-apps/iproute2: backport setns check fix (diff)
downloadgentoo-91f91926.tar.gz
gentoo-91f91926.tar.bz2
gentoo-91f91926.zip
dev-python/QtPy: take pyqt6/pyside6 into account 2.1.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/QtPy/QtPy-2.1.0-r4.ebuild (renamed from dev-python/QtPy/QtPy-2.1.0-r3.ebuild)3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/QtPy/QtPy-2.1.0-r3.ebuild b/dev-python/QtPy/QtPy-2.1.0-r4.ebuild
index 967021dd8836..ddebeff472ae 100644
--- a/dev-python/QtPy/QtPy-2.1.0-r3.ebuild
+++ b/dev-python/QtPy/QtPy-2.1.0-r4.ebuild
@@ -122,6 +122,9 @@ src_prepare() {
sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
sed -i -e "s/from PySide2.QtCore import/raise ImportError #/" qtpy/__init__.py || die
fi
+ sed -i -e "s/from PyQt6.QtCore import/raise ImportError #/" qtpy/__init__.py || die
+ sed -i -e "s/from PySide6 import/raise ImportError #/" qtpy/__init__.py || die
+ sed -i -e "s/from PySide6.QtCore import/raise ImportError #/" qtpy/__init__.py
}
python_test() {