summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 22:57:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:40 +0100
commit91fa2ca3b9d59cdfc65fe2b98c299c65843a651c (patch)
tree92b3291a754bc021e6282b7da736d8de306c036e
parentmedia-gfx/lximage-qt: add version 0.16.0 (diff)
downloadgentoo-91fa2ca3b9d59cdfc65fe2b98c299c65843a651c.tar.gz
gentoo-91fa2ca3b9d59cdfc65fe2b98c299c65843a651c.tar.bz2
gentoo-91fa2ca3b9d59cdfc65fe2b98c299c65843a651c.zip
media-sound/pavucontrol-qt: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/pavucontrol-qt/Manifest1
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-0.16.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/Manifest b/media-sound/pavucontrol-qt/Manifest
index ce03bfca4e53..505611030c55 100644
--- a/media-sound/pavucontrol-qt/Manifest
+++ b/media-sound/pavucontrol-qt/Manifest
@@ -1 +1,2 @@
DIST pavucontrol-qt-0.15.0.tar.xz 97480 BLAKE2B 183c3cbbe87b6867bb116041d41dd29f5ba72156e9078a4f09e5ffcbd3e123f6511cb06c99ce3cc8ce243a0551b132438bad7b14ae759cc775974c2ad3388bf3 SHA512 c77b0c7403c24df7839598aa46a6076e9ce84a102866a8917c6b8535f1a2b15baacd63e9ddf6bf0b7e914e7c681f0e10bbe378a641bc71144c1b22bc918e4600
+DIST pavucontrol-qt-0.16.0.tar.xz 99952 BLAKE2B 926e248f61b1652af04f772c09bc000d0f368ba6449cade308275473e970068a58ca25cccea5e4bea289424b507e3d24f30d54d76c13096e0e8047c5ea996950 SHA512 781122b57321cf1e3eff2210e7cb949c819d0148050897d3a9673e846c28fae7a926b4d840c603dac9dace8126bfc49179a737101f4d5b6ad4fe5946d82bd0d5
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-0.16.0.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-0.16.0.ebuild
new file mode 100644
index 000000000000..5b1a8c77bf4b
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-0.16.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt GUI Pulseaudio Mixer"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtwidgets:5
+ media-sound/pulseaudio[glib]
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"