summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 10:00:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 10:02:32 +0100
commit9209a0540baa65332bca29560130845016f838f4 (patch)
treebac9e3d16cafea6d279a703d9043f73606fdaca6
parentdev-python/clang-python: Add 13.x live ebuild (diff)
downloadgentoo-9209a054.tar.gz
gentoo-9209a054.tar.bz2
gentoo-9209a054.zip
dev-python/lit: Add 13.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lit/lit-13.0.0.9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/lit/lit-13.0.0.9999.ebuild b/dev-python/lit/lit-13.0.0.9999.ebuild
new file mode 100644
index 000000000000..cd8a5985d342
--- /dev/null
+++ b/dev-python/lit/lit-13.0.0.9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}