summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-05-05 06:52:06 -0700
committerLars Wendler <polynomial-c@gentoo.org>2021-05-05 20:51:47 +0200
commit922639c43726d0ffd0c11371e554d6b817ceee60 (patch)
tree100e05f22709a9a37665e111e0367ba25b76290b
parentapp-il8n/xcin: Fix for slibtool (diff)
downloadgentoo-922639c4.tar.gz
gentoo-922639c4.tar.bz2
gentoo-922639c4.zip
dev-libs/openct: Fix for slibtool
Thanks-to: orbea <orbea@riseup.net> Upstream: https://github.com/OpenSC/openct/commit/86abf3c Upstream: https://github.com/OpenSC/openct/commit/f329c26 Closes: https://bugs.gentoo.org/780033 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/openct/files/openct-0.6.20-automake.patch24
-rw-r--r--dev-libs/openct/files/openct-0.6.20-slibtool.patch34
-rw-r--r--dev-libs/openct/openct-0.6.20-r4.ebuild12
-rw-r--r--dev-libs/openct/openct-0.6.20-r5.ebuild12
4 files changed, 80 insertions, 2 deletions
diff --git a/dev-libs/openct/files/openct-0.6.20-automake.patch b/dev-libs/openct/files/openct-0.6.20-automake.patch
new file mode 100644
index 000000000000..451af6a8a50e
--- /dev/null
+++ b/dev-libs/openct/files/openct-0.6.20-automake.patch
@@ -0,0 +1,24 @@
+From 86abf3cbddbdc590dbb2ff5b0bda263e42595b88 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Wed, 10 Oct 2012 08:48:02 +0000
+Subject: [PATCH] build: fix issue with latest automake
+
+---
+ etc/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/etc/Makefile.am b/etc/Makefile.am
+index ff66d4e..dc00f47 100644
+--- a/etc/Makefile.am
++++ b/etc/Makefile.am
+@@ -30,8 +30,8 @@ dist_noinst_DATA += openct.usermap
+ endif
+
+
+-sysconf_DATA=#required in order to create dir
+-install-exec-hook: install-sysconfDATA openct.conf
++install-exec-hook: openct.conf
++ $(MKDIR_P) "$(DESTDIR)$(sysconfdir)"
+ if [ -f "$(DESTDIR)$(sysconfdir)/openct.conf" ]; then \
+ $(INSTALL_DATA) openct.conf "$(DESTDIR)$(sysconfdir)/openct.conf.new"; \
+ else \
diff --git a/dev-libs/openct/files/openct-0.6.20-slibtool.patch b/dev-libs/openct/files/openct-0.6.20-slibtool.patch
new file mode 100644
index 000000000000..0c0af2e1bd94
--- /dev/null
+++ b/dev-libs/openct/files/openct-0.6.20-slibtool.patch
@@ -0,0 +1,34 @@
+From f329c2663bde748d4a8fc462a1ea7bbc4ab47b36 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 27 Sep 2013 23:27:24 +0300
+Subject: [PATCH] build: use newer libtool -shared option
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ src/ctapi/Makefile.am | 2 +-
+ src/pcsc/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ctapi/Makefile.am b/src/ctapi/Makefile.am
+index 25627a3..c837820 100644
+--- a/src/ctapi/Makefile.am
++++ b/src/ctapi/Makefile.am
+@@ -8,4 +8,4 @@ libopenctapi_la_LIBADD = $(top_builddir)/src/ct/libopenct.la
+ libopenctapi_la_CFLAGS = $(AM_CFLAGS) \
+ -I$(top_srcdir)/src/include \
+ -I$(top_builddir)/src/include
+-libopenctapi_la_LDFLAGS = -avoid-version -no-undefined --module
++libopenctapi_la_LDFLAGS = -avoid-version -no-undefined -module -shared
+diff --git a/src/pcsc/Makefile.am b/src/pcsc/Makefile.am
+index 9986621..6aff8b8 100644
+--- a/src/pcsc/Makefile.am
++++ b/src/pcsc/Makefile.am
+@@ -5,7 +5,7 @@ lib_LTLIBRARIES = openct-ifd.la
+ endif
+
+ openct_ifd_la_SOURCES = pcsc.c
+-openct_ifd_la_LDFLAGS = -module -avoid-version -no-undefined
++openct_ifd_la_LDFLAGS = -module -shared -avoid-version -no-undefined
+ openct_ifd_la_LIBADD = $(PCSC_LIBS) $(top_builddir)/src/ctapi/libopenctapi.la
+ openct_ifd_la_CFLAGS = $(AM_CFLAGS) \
+ -I$(top_srcdir)/src/include \
diff --git a/dev-libs/openct/openct-0.6.20-r4.ebuild b/dev-libs/openct/openct-0.6.20-r4.ebuild
index 7c44328e3709..f73005a37633 100644
--- a/dev-libs/openct/openct-0.6.20-r4.ebuild
+++ b/dev-libs/openct/openct-0.6.20-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic udev user
+inherit autotools flag-o-matic udev user
DESCRIPTION="library for accessing smart card terminals"
HOMEPAGE="https://github.com/OpenSC/openct/wiki"
@@ -21,11 +21,21 @@ RDEPEND="pcsc-lite? ( >=sys-apps/pcsc-lite-1.7.2-r1:= )
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-slibtool.patch
+)
+
pkg_setup() {
enewgroup openct
enewuser openctd
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
use debug && append-cppflags -DDEBUG_IFDH
diff --git a/dev-libs/openct/openct-0.6.20-r5.ebuild b/dev-libs/openct/openct-0.6.20-r5.ebuild
index 12d4c000e8c6..6183a18acb12 100644
--- a/dev-libs/openct/openct-0.6.20-r5.ebuild
+++ b/dev-libs/openct/openct-0.6.20-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic udev
+inherit autotools flag-o-matic udev
DESCRIPTION="library for accessing smart card terminals"
HOMEPAGE="https://github.com/OpenSC/openct/wiki"
@@ -27,6 +27,16 @@ RDEPEND="
"
BDEPEND="doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-slibtool.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
use debug && append-cppflags -DDEBUG_IFDH