summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-17 21:21:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-17 21:21:49 +0300
commit92368e84d620ceb33821094cbbdec171cbae3409 (patch)
tree894f3fb49ff953ceb300cc01bd4da336d3a084d8
parentapp-admin/awscli: add 1.25.53 (diff)
downloadgentoo-92368e84.tar.gz
gentoo-92368e84.tar.bz2
gentoo-92368e84.zip
dev-python/matplotlib-inline: add 0.1.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/matplotlib-inline/Manifest1
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/matplotlib-inline/Manifest b/dev-python/matplotlib-inline/Manifest
index c9fb0311408f..09cb11b0ea01 100644
--- a/dev-python/matplotlib-inline/Manifest
+++ b/dev-python/matplotlib-inline/Manifest
@@ -1 +1,2 @@
DIST matplotlib-inline-0.1.3.gh.tar.gz 7337 BLAKE2B 995b6e5ce9068760e701e3b429d2187bdc7e7c5b989d54a9fb1f8b5f385f91c6a3621a54d5a1e62c9000737f5f42d9ceae5be7f36b664b7e06ff9c712e6d76ac SHA512 684821204faa3cb35c46663b8c8cb8f0ba5d4f761d15bc708de69c98753685c89da1d330087bcfa970792de592188768dc068accc471d55360f551e44cf4a79a
+DIST matplotlib-inline-0.1.5.gh.tar.gz 7520 BLAKE2B 90fe7ed66b6d0ef7fd2b2a9478847adaa37af281ea383b60a1d01091d1be338411ccb2480e4bf34f0722e29cf6564a58ab358718c7704ac0c1c09375ba043627 SHA512 2a12d675ae6db1657f7202450ef3d889618c896d3571fd1a6c43b75fba1d72e80e49a06d55f7c333381b1afd2cd4a9ef282b5bcbadd2b53a19e02bd3f8bc9301
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.5.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.5.ebuild
new file mode 100644
index 000000000000..ddc247e6a9b8
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"