summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-18 12:25:28 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-18 13:01:21 +0200
commit92509bc0dfe7edafeb1d8f808b07b820ab0931d0 (patch)
treef9a3d530400033f8d631dbf5ddd1e9809644215e
parentmedia-sound/quark: Drop old (diff)
downloadgentoo-92509bc0dfe7edafeb1d8f808b07b820ab0931d0.tar.gz
gentoo-92509bc0dfe7edafeb1d8f808b07b820ab0931d0.tar.bz2
gentoo-92509bc0dfe7edafeb1d8f808b07b820ab0931d0.zip
app-office/grisbi: Update ebuild and fix deps on openssl
Package-Manager: portage-2.3.0
-rw-r--r--app-office/grisbi/grisbi-1.0.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-office/grisbi/grisbi-1.0.0-r1.ebuild b/app-office/grisbi/grisbi-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..e5934405f2ad
--- /dev/null
+++ b/app-office/grisbi/grisbi-1.0.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/grisbi%20stable/1.0.x/${P}.tar.bz2"
+IUSE="libressl nls ofx ssl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=dev-libs/glib-2.18.0:2
+ >=x11-libs/gtk+-2.12.0:2
+ x11-misc/xdg-utils
+ ssl? (
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( >=dev-libs/openssl-0.9.5:0= ) )
+ ofx? ( >=dev-libs/libofx-0.7.0 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --with-libxml2 \
+ --without-cunit \
+ --disable-static \
+ $(use_with ssl openssl) \
+ $(use_with ofx) \
+ $(use_enable nls)
+}