summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-17 21:41:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-17 21:41:33 +0200
commit925651d3337c1ad824d5dca535bd42c8a0cdd3b8 (patch)
tree13df54a011bfdba0d5a5b58307e094211a1732fd
parentdev-python/pyscard: Bump to 2.0.1 (diff)
downloadgentoo-925651d3.tar.gz
gentoo-925651d3.tar.bz2
gentoo-925651d3.zip
net-misc/electrum: Bump to 4.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/electrum/Manifest1
-rw-r--r--net-misc/electrum/electrum-4.1.4.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
index df71e72cf8b4..b4eb067eb933 100644
--- a/net-misc/electrum/Manifest
+++ b/net-misc/electrum/Manifest
@@ -1,2 +1,3 @@
DIST electrum-4.1.2.gh.tar.gz 4926068 BLAKE2B e5d543c963cfec523e80e2de8b6a44c1845bdee23524c182e86efb7ff41caeaccebbefab2b8dda9c1e027410809d42be30db6dbc20fd877f3c749619478a6977 SHA512 4db8f8061ae149a5d9770b8c30676aa85ee66eb71052763e29d551317484b597628aad702370486b466c981688488f5a4592ae30a426e5fcd9250bc1a69a890a
DIST electrum-4.1.3.gh.tar.gz 4958955 BLAKE2B 0d338261ada16d5f1a9b01532fd976094ed7105204f45997c789c01c757d85e7d8a47d20935f848a7e52db1755f953d999e974500cb016f34088642f046c6637 SHA512 af74cfd5ef3f5bc8a788a55b3459029fec7a08b693a3e58133b74a5ad782d4a716061e8619bef633fcfee8a9d1989980c1e8e8e314cea2431e473745660e773e
+DIST electrum-4.1.4.gh.tar.gz 4959040 BLAKE2B ac17588f542bde4d368065815688c36afac2c5d0ace849a7dfe997113d2c0d6c23512c8091d039a73436709f7104fb0c86aabe1a81448ae0d26644343c4cc588 SHA512 e6e0d01f1f32389da95c3fa131c8aaaeeaf38af1203cddbd06cbfb1b09070cc89fcd30a9c9979f5b06d4ba40001d046690aea6501342ce1669271c6646717be9
diff --git a/net-misc/electrum/electrum-4.1.4.ebuild b/net-misc/electrum/electrum-4.1.4.ebuild
new file mode 100644
index 000000000000..a8c551d5f9bb
--- /dev/null
+++ b/net-misc/electrum/electrum-4.1.4.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="ncurses?"
+
+inherit desktop distutils-r1 xdg-utils
+
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="https://electrum.org/"
+SRC_URI="
+ https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli ncurses qrcode +qt5"
+REQUIRED_USE="|| ( cli ncurses qt5 )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libsecp256k1
+ >=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
+ =dev-python/aiorpcX-0.19*[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/bitstring[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.12[${PYTHON_USEDEP}]
+ qrcode? ( media-gfx/zbar[v4l] )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ ncurses? ( $(python_gen_impl_dep 'ncurses') )
+"
+BDEPEND="
+ test? (
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ eapply "${FILESDIR}/3.1.2-no-user-root.patch"
+ eapply "${FILESDIR}/3.3.2-desktop.patch"
+
+ # unbind aiorpcX dep
+ sed -e '/aiorpcx/s:,<0.19::' \
+ -i contrib/requirements/requirements.txt || die
+ sed -e '/aiorpcx/s:raise.*:pass:' \
+ -i run_electrum || die
+
+ # Prevent icon from being installed in the wrong location
+ sed -i '/icons_dirname/d' setup.py || die
+
+ # use backwards-compatible cryptodome API
+ sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
+
+ local bestgui
+ if use qt5; then
+ bestgui=qt
+ elif use ncurses; then
+ bestgui=text
+ else
+ bestgui=stdio
+ fi
+ sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
+
+ eapply_user
+
+ xdg_environment_reset
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ doicon -s 128 electrum/gui/icons/${PN}.png
+ dodoc RELEASE-NOTES
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}