summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-04-27 00:00:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-04-27 00:00:28 +0200
commit927075c7e459573e4158a8bd47251412fcb37007 (patch)
tree65a2050a0d899c385986614c5c8241894520c0a4
parentnet-irc/irssi-otr: stable for amd64. (diff)
downloadgentoo-927075c7.tar.gz
gentoo-927075c7.tar.bz2
gentoo-927075c7.zip
dev-libs/liblognorm: Bump to v2.0.5
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--dev-libs/liblognorm/Manifest1
-rw-r--r--dev-libs/liblognorm/liblognorm-2.0.5.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/liblognorm/Manifest b/dev-libs/liblognorm/Manifest
index 51941a2ca57a..af8a577bee12 100644
--- a/dev-libs/liblognorm/Manifest
+++ b/dev-libs/liblognorm/Manifest
@@ -4,3 +4,4 @@ DIST liblognorm-2.0.1.tar.gz 657390 BLAKE2B afdec1d1afbf0cfae7a317a4bdfd109457f3
DIST liblognorm-2.0.2.tar.gz 658976 BLAKE2B 44a928ca4d8934f9b6f0b81610315a7de1f0968d2d62fddf9e919699c2fa10d1bce94f0a46a40ff9bf6521ae7dc7a88440febd1b770af9dc3983d13e5a10e188 SHA512 7cb1e20c895859072b9d6f0b3c2dd89874192dce6d11878a4c3eb0b0d9f1691d97205a61290e9cd07deeaa71c58f5fb6a4c1f14bd206119d690cf84c107ccbe4
DIST liblognorm-2.0.3.tar.gz 660680 BLAKE2B d5da4386026faae43dbcbe36aacc47687ef8636be2223a596a9915adee731535083016e5d680c9169cb8d4262a7f3d2342a9e6af566108a635f9d49fcf2cfec5 SHA512 8f343f3029c506a9c060b1b55e478da9ceedc1fbf27ca53a991ffbddb397383adfee2d79beb174a6c997599ee3c0fa4bbc9925fa850e5bf4f4d7b181ddae7cdb
DIST liblognorm-2.0.4.tar.gz 665898 BLAKE2B 80bcd114d2be81f8eea847e699b7e8ade9ca37d4376f64af81bfaba1a440e1efbab579235aba775c46a9d011e930453d2c001de525577b7775784e7152b3e700 SHA512 3c7cbf0c8c320708615218009354d198ba0893632ca464a07270f59d137753dfc7ad6dae66b565660f14e9285f9c8964824d36070b1872b6c633589b4996ba02
+DIST liblognorm-2.0.5.tar.gz 667709 BLAKE2B 9f2a774c2378caa460a1f11e21570e719f83e782c5731a35921099b1b31397495ea2a4baebd489d186526eb2d011f2ab30d971713a8083c1ae02168d3f632ce8 SHA512 2b36fabfa8b751127d47f307833414d339ae43bad5b687ce6ac42a961021f9a515703ca0c4808e098ef49be3a943abdbf307f90995a2331c6e266167ef041d00
diff --git a/dev-libs/liblognorm/liblognorm-2.0.5.ebuild b/dev-libs/liblognorm/liblognorm-2.0.5.ebuild
new file mode 100644
index 000000000000..53b1689f8f12
--- /dev/null
+++ b/dev-libs/liblognorm/liblognorm-2.0.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fast samples-based log normalization library"
+HOMEPAGE="http://www.liblognorm.com"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/rsyslog/${PN}.git"
+
+ inherit git-r3
+else
+ SRC_URI="http://www.liblognorm.com/files/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux"
+fi
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0/5.1.0"
+IUSE="debug doc static-libs test"
+
+RDEPEND="
+ >=dev-libs/libestr-0.1.3
+ >=dev-libs/libfastjson-0.99.2:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/autoconf-archive-2015.02.04
+ virtual/pkgconfig
+ doc? ( >=dev-python/sphinx-1.2.2 )
+"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # regexp disabled due to https://github.com/rsyslog/liblognorm/issues/143
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ --disable-Werror
+ $(use_enable doc docs)
+ $(use_enable test testbench)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ --disable-regexp
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # When adding new tests via patches we have to make them executable
+ einfo "Adjusting permissions of test scripts ..."
+ find "${S}"/tests -type f -name '*.sh' \! -perm -111 -exec chmod a+x '{}' \; || \
+ die "Failed to adjust test scripts permission"
+
+ emake --jobs 1 check
+}
+
+src_install() {
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}