summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-30 23:04:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-30 23:44:03 +0200
commit9284c333c4c23eb00240f6a38533ecb2d27262dd (patch)
treeeda3c814146017a763de3508c7e432323008ef87
parentmedia-libs/mlt: fix crash in composite when PGM luma fails to load (diff)
downloadgentoo-9284c333.tar.gz
gentoo-9284c333.tar.bz2
gentoo-9284c333.zip
media-libs/mlt: Fix OpenCV tracker double deletion crash
Upstream commit 5e906b13cab7f28bbef43a33c20dbe24c2ca1f8d Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/mlt/files/mlt-6.20.0-opencv-double-del-crash.patch21
-rw-r--r--media-libs/mlt/mlt-6.20.0-r2.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/media-libs/mlt/files/mlt-6.20.0-opencv-double-del-crash.patch b/media-libs/mlt/files/mlt-6.20.0-opencv-double-del-crash.patch
new file mode 100644
index 000000000000..7f764965046d
--- /dev/null
+++ b/media-libs/mlt/files/mlt-6.20.0-opencv-double-del-crash.patch
@@ -0,0 +1,21 @@
+From 5e906b13cab7f28bbef43a33c20dbe24c2ca1f8d Mon Sep 17 00:00:00 2001
+From: Jean-Baptiste Mardelle <jb@kdenlive.org>
+Date: Tue, 17 Mar 2020 18:22:04 +0100
+Subject: [PATCH] Fix OpenCV tracker double deletion crash. Fixes #532
+
+---
+ src/modules/opencv/filter_opencv_tracker.cpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/modules/opencv/filter_opencv_tracker.cpp b/src/modules/opencv/filter_opencv_tracker.cpp
+index 04a5f0b09..533f0f513 100644
+--- a/src/modules/opencv/filter_opencv_tracker.cpp
++++ b/src/modules/opencv/filter_opencv_tracker.cpp
+@@ -351,7 +351,6 @@ static mlt_frame filter_process( mlt_filter filter, mlt_frame frame )
+ static void filter_close( mlt_filter filter )
+ {
+ private_data* data = (private_data*) filter->child;
+- free ( data->tracker );
+ free ( data );
+ filter->child = NULL;
+ filter->close = NULL;
diff --git a/media-libs/mlt/mlt-6.20.0-r2.ebuild b/media-libs/mlt/mlt-6.20.0-r2.ebuild
index 745d49592280..cef89ce3ef6c 100644
--- a/media-libs/mlt/mlt-6.20.0-r2.ebuild
+++ b/media-libs/mlt/mlt-6.20.0-r2.ebuild
@@ -90,6 +90,7 @@ PATCHES=(
"${FILESDIR}"/${P}-nullpointer-crash.patch
"${FILESDIR}"/${P}-crash-w-unsupported-preview-scale.patch
"${FILESDIR}"/${P}-crash-in-composite.patch
+ "${FILESDIR}"/${P}-opencv-double-del-crash.patch
)
pkg_setup() {