summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-08-16 12:28:42 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-08-16 12:29:28 +0200
commit92898ad5b8d132ed7c36a6ada6565bc50e88255f (patch)
tree5ee918e3be4ef1ba527c42624ec26531735f4e38
parentapp-backup/dar: Removed old. (diff)
downloadgentoo-92898ad5b8d132ed7c36a6ada6565bc50e88255f.tar.gz
gentoo-92898ad5b8d132ed7c36a6ada6565bc50e88255f.tar.bz2
gentoo-92898ad5b8d132ed7c36a6ada6565bc50e88255f.zip
net-print/hplip: Version bump to 3.16.7
Package-Manager: portage-2.3.0
-rw-r--r--net-print/hplip/Manifest1
-rw-r--r--net-print/hplip/hplip-3.16.7.ebuild264
2 files changed, 265 insertions, 0 deletions
diff --git a/net-print/hplip/Manifest b/net-print/hplip/Manifest
index 1804893f5f99..965aba6f27e5 100644
--- a/net-print/hplip/Manifest
+++ b/net-print/hplip/Manifest
@@ -4,3 +4,4 @@ DIST hplip-3.16.2-patches-1.tar.xz 8188 SHA256 8a9a78e0caac1731eae79f047a6054b41
DIST hplip-3.16.3.tar.gz 22408596 SHA256 42d2302ee38bda41caa0f2f9524a91f531e3aa432814ffd45b3e5c396dc30194 SHA512 32d2f88c0983208e77592f73bf65cf2900cd6aa234d09220a18b45b5fc4bd0d10e9cfc8c7a10639e5a51ad5f5d0f8ed7bd477d08c86b89c633a1bbcd42682915 WHIRLPOOL b287ecf80c2e7b0da0de0afefcf60c507f9d42c74dbba1e745b4b43f253a5b0dedb6398a1f073e14d196296da47764e983138c0151e05bfc7a5dd416458662a0
DIST hplip-3.16.5-patches-1.tar.xz 8200 SHA256 98866e57a247e7a30d9cd584ed9411aa79a6185294a73b4cc5961efe9a5e5fa6 SHA512 36d33da5fc4105183cbc5137845ddccd8ab2b6abbff053a3a51f3da61c26c2d9d48dcb735345fb453abd67b6a0797aa337102c366cce037bc7006599b20b1646 WHIRLPOOL 8ac91bdefeb177c092b1d6de16474e8e1da57ad046dbc579f14fd40a27d1837d9bf142573137ef8d91c37dc7b03ca908fd5bfad23a9815af2015b521091c2700
DIST hplip-3.16.5.tar.gz 22662561 SHA256 c609516003c9613c51e2ef24503e535f8d93693dd618cb6397a2d71f70315ed9 SHA512 5fdf7dc710158af2aff651f23df9da88dd8443668f738cc143be66bd53952189dd3c87f73741a5af7369d48d465d6dd3936e45eff59bfc4146243c4897a8434b WHIRLPOOL 003a663048210d9c4ce53ac8de009df48454c7d2a73cf8685d90c2cc6a8b8952363009fa565f68f517858c5e36ac3ffa74fa282a7f37cd0b229741fd4824d457
+DIST hplip-3.16.7.tar.gz 22872438 SHA256 9dfe0642636f2b40cb7f1c178e7ab8a794f4d0be8f75be348d1b681793f3ffc2 SHA512 68fb6748bd04809c58f0739c31487b79042f8ae89a642aa3fdcb9ee4474a319ab880c3e95b318465a70ff2ee112b576a398ef98ae3a0de45e60fba3357af6abb WHIRLPOOL 9a7a5ea51214ffd4b1604e613ccbf726ebca9cdc3ef0fe2c221611d67da9b97dcdfa01079396339e7f2382d2040f3d4e7da7782cdc5372c08a25e0c66d83f9c3
diff --git a/net-print/hplip/hplip-3.16.7.ebuild b/net-print/hplip/hplip-3.16.7.ebuild
new file mode 100644
index 000000000000..291f450ee616
--- /dev/null
+++ b/net-print/hplip/hplip-3.16.7.ebuild
@@ -0,0 +1,264 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads,xml"
+
+inherit eutils linux-info python-single-r1 readme.gentoo-r1 udev autotools
+
+DESCRIPTION="HP Linux Imaging and Printing - Print, scan, fax drivers and service tools"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ https://dev.gentoo.org/~billie/distfiles/${PN}-3.16.5-patches-1.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+IUSE="doc fax +hpcups hpijs kde -libusb0 minimal parport policykit +qt4 qt5 scanner +snmp static-ppds X"
+
+# dependency on dev-python/notify-python dropped due to python 3 incompatibility
+# possible replacement notify2 (https://pypi.python.org/pypi/notify2/0.3) not in tree
+
+COMMON_DEPEND="
+ virtual/jpeg:0
+ hpijs? (
+ || ( >=net-print/cups-filters-1.0.43-r1[foomatic] >=net-print/foomatic-filters-3.0.20080507[cups] )
+ )
+ >=net-print/cups-1.4.0
+ !minimal? (
+ ${PYTHON_DEPS}
+ !libusb0? ( virtual/libusb:1 )
+ libusb0? ( virtual/libusb:0 )
+ scanner? ( >=media-gfx/sane-backends-1.0.19-r1 )
+ fax? ( >=sys-apps/dbus-1.6.8-r1 )
+ snmp? (
+ net-analyzer/net-snmp
+ dev-libs/openssl:0
+ )
+ )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ >=app-text/ghostscript-gpl-8.71-r3
+ policykit? ( sys-auth/polkit )
+ !minimal? (
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ kernel_linux? ( virtual/udev )
+ scanner? (
+ >=dev-python/reportlab-3.1.44-r2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
+ X? ( || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ ) )
+ )
+ fax? ( >=dev-python/reportlab-3.1.44-r2[${PYTHON_USEDEP}] )
+ qt4? ( >=dev-python/PyQt4-4.11.1[dbus,X,${PYTHON_USEDEP}] )
+ qt5? ( >=dev-python/PyQt5-5.5.1[dbus,gui,${PYTHON_USEDEP}] )
+ )"
+
+REQUIRED_USE="
+ !minimal? ( ${PYTHON_REQUIRED_USE} )
+ !minimal? ( qt4? ( !qt5 ) )
+"
+
+CONFIG_CHECK="~PARPORT ~PPDEV"
+ERROR_PARPORT="Please make sure kernel parallel port support is enabled (PARPORT and PPDEV)."
+
+#DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+For more information on setting up your printer please take
+a look at the hplip section of the gentoo printing guide:
+https://wiki.gentoo.org/wiki/Printing
+
+Any user who wants to print must be in the lp group.
+"
+
+pkg_setup() {
+ use !minimal && python-single-r1_pkg_setup
+
+ ! use qt4 && ! use qt5 && ewarn "You need USE=qt4 or USE=qt5 for the hplip GUI."
+
+ use scanner && ! use X && ewarn "You need USE=X for the scanner GUI."
+
+ if ! use hpcups && ! use hpijs ; then
+ ewarn "Installing neither hpcups (USE=-hpcups) nor hpijs (USE=-hpijs) driver,"
+ ewarn "which is probably not what you want."
+ ewarn "You will almost certainly not be able to print."
+ fi
+
+ if use minimal ; then
+ ewarn "Installing driver portions only, make sure you know what you are doing."
+ ewarn "Depending on the USE flags set for hpcups or hpijs the appropiate driver"
+ ewarn "is installed. If both USE flags are set hpijs overrides hpcups."
+ else
+ use parport && linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ eapply "${WORKDIR}/patches"
+
+ default
+
+ if use !minimal ; then
+ python_export EPYTHON PYTHON
+ python_fix_shebang .
+ fi
+
+ # Make desktop files follow the specification
+ # Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=443680
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/1080324
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Encoding=.*/d' hplip.desktop.in || die
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Version=.*/d' \
+ -e '/^Comment=.*/d' hplip-systray.desktop.in || die
+
+ # Fix for Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=345725
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/880847,
+ # https://bugs.launchpad.net/hplip/+bug/500086
+ local udevdir=$(get_udevdir)
+ sed -i -e "s|/etc/udev|${udevdir}|g" \
+ $(find . -type f -exec grep -l /etc/udev {} +) || die
+
+ # Force recognition of Gentoo distro by hp-check
+ sed -i \
+ -e "s:file('/etc/issue', 'r').read():'Gentoo':" \
+ installer/core_install.py || die
+
+ # Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
+ # The hpcups driver does not use foomatic-rip
+ local i
+ for i in ppd/hpijs/*.ppd.gz ; do
+ rm -f ${i}.temp || die
+ gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
+ gzip > ${i}.temp || die
+ mv ${i}.temp ${i} || die
+ done
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf drv_build minimal_build
+
+ if use qt4 || use qt5 ; then
+ myconf="${myconf} --enable-gui-build"
+ else
+ myconf="${myconf} --disable-gui-build"
+ fi
+
+ if use fax || use qt4 || use qt5 ; then
+ myconf="${myconf} --enable-dbus-build"
+ else
+ myconf="${myconf} --disable-dbus-build"
+ fi
+
+ if use libusb0 ; then
+ myconf="${myconf} --enable-libusb01_build"
+ else
+ myconf="${myconf} --disable-libusb01_build"
+ fi
+
+ if use hpcups ; then
+ drv_build="$(use_enable hpcups hpcups-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-cups-ppd-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ else
+ drv_build="${drv_build} --enable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+ else
+ drv_build="--disable-hpcups-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+
+ if use hpijs ; then
+ drv_build="${drv_build} $(use_enable hpijs hpijs-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-foomatic-ppd-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ else
+ drv_build="${drv_build} --enable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+ else
+ drv_build="${drv_build} --disable-hpijs-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+
+ if use minimal ; then
+ if use hpijs ; then
+ minimal_build="--enable-hpijs-only-build"
+ else
+ minimal_build="--disable-hpijs-only-build"
+ fi
+ if use hpcups ; then
+ minimal_build="${minimal_build} --enable-hpcups-only-build"
+ else
+ minimal_build="${minimal_build} --disable-hpcups-only-build"
+ fi
+ fi
+
+ econf \
+ --disable-cups11-build \
+ --disable-lite-build \
+ --disable-foomatic-rip-hplip-install \
+ --disable-shadow-build \
+ --disable-qt3 \
+ --disable-udev_sysfs_rules \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ --with-cupsfilterdir=$(cups-config --serverbin)/filter \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-htmldir=/usr/share/doc/${PF}/html \
+ ${myconf} \
+ ${drv_build} \
+ ${minimal_build} \
+ $(use_enable doc doc-build) \
+ $(use_enable fax fax-build) \
+ $(use_enable parport pp-build) \
+ $(use_enable scanner scan-build) \
+ $(use_enable snmp network-build) \
+ $(use_enable qt4) \
+ $(use_enable qt5) \
+ $(use_enable policykit)
+}
+
+src_install() {
+ default
+
+ # Installed by sane-backends
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=201023
+ rm -f "${D}"/etc/sane.d/dll.conf || die
+
+ rm -f "${D}"/usr/share/doc/${PF}/{copyright,README_LIBJPG,COPYING} || die
+ rmdir --ignore-fail-on-non-empty "${D}"/usr/share/doc/${PF}/ || die
+
+ # Remove hal fdi files
+ rm -rf "${D}"/usr/share/hal || die
+
+ prune_libtool_files --all
+
+ if use !minimal ; then
+ python_export EPYTHON PYTHON
+ python_optimize "${D}"/usr/share/hplip
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}