summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2021-02-19 15:10:49 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2021-02-19 15:11:09 +0100
commit929f4686fe4c11cc10784a14ae09ae08e5fb4f50 (patch)
tree5d62d64b4f429f227fae7da8b1abfbaa5e87ea71
parentnet-im/signal-desktop-bin: add missing die to 1.40.0-r1 (diff)
downloadgentoo-929f4686fe4c11cc10784a14ae09ae08e5fb4f50.tar.gz
gentoo-929f4686fe4c11cc10784a14ae09ae08e5fb4f50.tar.bz2
gentoo-929f4686fe4c11cc10784a14ae09ae08e5fb4f50.zip
net-vpn/wireguard-modules: bump to v1.0.20210219
Also drop the stable version, which is really less stable than testing, and not something I want to maintain. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--net-vpn/wireguard-modules/Manifest3
-rw-r--r--net-vpn/wireguard-modules/wireguard-modules-1.0.20201221.ebuild99
-rw-r--r--net-vpn/wireguard-modules/wireguard-modules-1.0.20210219.ebuild (renamed from net-vpn/wireguard-modules/wireguard-modules-1.0.20210124.ebuild)0
3 files changed, 1 insertions, 101 deletions
diff --git a/net-vpn/wireguard-modules/Manifest b/net-vpn/wireguard-modules/Manifest
index c3c91951da6c..494d5071909a 100644
--- a/net-vpn/wireguard-modules/Manifest
+++ b/net-vpn/wireguard-modules/Manifest
@@ -1,2 +1 @@
-DIST wireguard-linux-compat-1.0.20201221.tar.xz 262596 BLAKE2B fffd0f3a5501aa5ad0e52f3210edf507b0db63230d59b3204104584cc2b1d739311262a0e0180ce5cd5d6e74c5228d01a631fdbba8be9788bda2d80df8cfcbd0 SHA512 1b06eeda525903661657cae4f462cf2ef464bce292b0a9ae37425d254142ed4137ca7a2296da0f11447f89a4d921c3cb7cee018a4f691131541f0ec32f99c458
-DIST wireguard-linux-compat-1.0.20210124.tar.xz 262500 BLAKE2B 3ba5de204040abf2c2049b4223f6adcf0c24ef85bcc10702e5f8e40e751dbc6c8d217ac4d1534f407a7cf5f078bbb2e9a82862043c7979cc69a45e33d6e0cfb6 SHA512 4438391eb6a6a1526cbb9b7eb7b8f8b2999bf425d5fca028f1a412d93bffaa6107be133d673e68add6eeeb86201aa080228706de2af00e69c0ac88ccb127e56e
+DIST wireguard-linux-compat-1.0.20210219.tar.xz 263964 BLAKE2B 9d8c3e17e1fe37b7148e02387e53ba8c7b4e1baf591253b30d69c1cfac459ea16f7f57d640588f2c550f0a3e0c33893ff1e378d7f494f8bfbabbc8eed46d67cd SHA512 1a0ef2ed96d7172f7726fb0e6699e2b49409e544c759df981951b7479f3798762761148cbc8eb5697282787aa8c4560e80690ef41711f6ab5c9d0568526762ac
diff --git a/net-vpn/wireguard-modules/wireguard-modules-1.0.20201221.ebuild b/net-vpn/wireguard-modules/wireguard-modules-1.0.20201221.ebuild
deleted file mode 100644
index a3aea3fe6a50..000000000000
--- a/net-vpn/wireguard-modules/wireguard-modules-1.0.20201221.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MODULES_OPTIONAL_USE="module"
-inherit linux-mod bash-completion-r1
-
-DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
-HOMEPAGE="https://www.wireguard.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.zx2c4.com/wireguard-linux-compat"
-else
- SRC_URI="https://git.zx2c4.com/wireguard-linux-compat/snapshot/wireguard-linux-compat-${PV}.tar.xz"
- S="${WORKDIR}/wireguard-linux-compat-${PV}"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug +module module-src"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-MODULE_NAMES="wireguard(kernel/drivers/net:src)"
-BUILD_TARGETS="module"
-CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
-
-pkg_setup() {
- if use module; then
- linux-mod_pkg_setup
- if [[ -f $KERNEL_DIR/include/uapi/linux/wireguard.h ]]; then
- eerror
- eerror "WireGuard has been merged upstream into this kernel. Therefore,"
- eerror "you no longer need this compatibility ebuild. Instead, simply"
- eerror "enable CONFIG_WIREGUARD=y in your kernel configuration."
- eerror
- die "Use CONFIG_WIREGUARD=y for this kernel, and do not use this package."
- elif kernel_is -lt 3 10 0 || kernel_is -ge 5 6 0; then
- die "This version of ${PN} requires Linux >= 3.10 and < 5.6."
- fi
- fi
-}
-
-src_compile() {
- BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
- use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
- use module && linux-mod_src_compile
-}
-
-src_install() {
- use module && linux-mod_src_install
- use module-src && emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src dkms-install
-}
-
-pkg_postinst() {
- if use module-src && ! use module; then
- einfo
- einfo "You have enabled the module-src USE flag without the module USE"
- einfo "flag. This means that sources are installed to"
- einfo "${ROOT}/usr/src/wireguard instead of having the"
- einfo "kernel module compiled. You will need to compile the module"
- einfo "yourself. Most likely, you don't want this USE flag, and should"
- einfo "rather use USE=module"
- einfo
- fi
-
- if use module; then
- linux-mod_pkg_postinst
- local old new
- if [[ $(uname -r) != "${KV_FULL}" ]]; then
- ewarn
- ewarn "You have just built WireGuard for kernel ${KV_FULL}, yet the currently running"
- ewarn "kernel is $(uname -r). If you intend to use this WireGuard module on the currently"
- ewarn "running machine, you will first need to reboot it into the kernel ${KV_FULL}, for"
- ewarn "which this module was built."
- ewarn
- elif [[ -f /sys/module/wireguard/version ]] && \
- old="$(< /sys/module/wireguard/version)" && \
- new="$(modinfo -F version "${ROOT}/lib/modules/${KV_FULL}/net/wireguard.ko" 2>/dev/null)" && \
- [[ $old != "$new" ]]; then
- ewarn
- ewarn "You appear to have just upgraded WireGuard from version v$old to v$new."
- ewarn "However, the old version is still running on your system. In order to use the"
- ewarn "new version, you will need to remove the old module and load the new one. As"
- ewarn "root, you can accomplish this with the following commands:"
- ewarn
- ewarn " # rmmod wireguard"
- ewarn " # modprobe wireguard"
- ewarn
- ewarn "Do note that doing this will remove current WireGuard interfaces, so you may want"
- ewarn "to gracefully remove them yourself prior."
- ewarn
- fi
- fi
-}
diff --git a/net-vpn/wireguard-modules/wireguard-modules-1.0.20210124.ebuild b/net-vpn/wireguard-modules/wireguard-modules-1.0.20210219.ebuild
index a057f7a62290..a057f7a62290 100644
--- a/net-vpn/wireguard-modules/wireguard-modules-1.0.20210124.ebuild
+++ b/net-vpn/wireguard-modules/wireguard-modules-1.0.20210219.ebuild