summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-25 11:13:50 +1000
committerSam James <sam@gentoo.org>2022-07-25 04:02:52 +0100
commit92a4a2f6cbc3a34a58b8c683a95a07a90fe56b44 (patch)
tree3795eba2ebfac01166042ccd44f4186c18947b95
parentapp-emulation/virtualbox-guest-additions: Stabilize 6.1.34-r3 x86, #860813 (diff)
downloadgentoo-92a4a2f6cbc3a34a58b8c683a95a07a90fe56b44.tar.gz
gentoo-92a4a2f6cbc3a34a58b8c683a95a07a90fe56b44.tar.bz2
gentoo-92a4a2f6cbc3a34a58b8c683a95a07a90fe56b44.zip
dev-haskell/x11: add 1.10.2
May close the below bug. The previous version 1.10-r1 dropped xinerama handling, while the version prior to that had retained it. This restores the xinerama handling. Bug: https://bugs.gentoo.org/860393 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/x11/Manifest1
-rw-r--r--dev-haskell/x11/x11-1.10.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/x11/Manifest b/dev-haskell/x11/Manifest
index 9875a838ab0a..5f5d5e5beee2 100644
--- a/dev-haskell/x11/Manifest
+++ b/dev-haskell/x11/Manifest
@@ -1,2 +1,3 @@
DIST X11-1.10.tar.gz 192493 BLAKE2B 7c951eaf3a009302b2b7d3a9aeb866b908e99f60b408aaae75375e0fbdd12254c283ad27a0e2354cc0c6be745fa507c0bf64a763c548037a640eb8927923246e SHA512 7976a151edf9a54e4278f65903ec6b177211f8209039c4e2747abddd9ed86db51a6e65c5359297443b5ade513d9ca8e452cff033d9d0261f3fb027113765bb89
DIST X11-1.9.2.tar.gz 190757 BLAKE2B cae5bd1e689bec914d612f59070ab5da3f604d33991ba885d83257337ca6d53089374e427f8bcfee2dd7504687b49b830ac98ab5947021c6c2d6e500123203ec SHA512 e9658c33b6dcbb6a42f1cc4a8976365506af94ddc15c32f73205b453934ef3232f3b383f8365b6aa6e69b51acfda4a0f3a8038f3164523b33781139a80582a41
+DIST x11-1.10.2.tar.gz 192634 BLAKE2B a42e24aea6287a0af7f1b96fd9603d494fc010c9659a69ffcc46bb8670993271fb67061f5026f201bf730dbe0670d485f2a4197cdba5fc6bbd4f36fca4d6dd8e SHA512 5013dc359e081900193efd201c38c41ca73bc8dae3610e8e3b46e42aad7ae4a5917ecd3219d77e40141be7179963aaa2454032c820945e93ff4310ef359b2df4
diff --git a/dev-haskell/x11/x11-1.10.2.ebuild b/dev-haskell/x11/x11-1.10.2.ebuild
new file mode 100644
index 000000000000..794d6d454c07
--- /dev/null
+++ b/dev-haskell/x11/x11-1.10.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.2.1.9999
+#hackport: flags: -pedantic
+CABAL_PN="X11"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="https://github.com/xmonad/X11"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="+xinerama"
+
+# add +xinerama to IUSE and RDEPEND on libXScrnSaver and libXinerama below
+RDEPEND=">=dev-haskell/data-default-class-0.1:=[profile?] <dev-haskell/data-default-class-0.2:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ xinerama? ( x11-libs/libXinerama )
+
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-pedantic \
+ --configure-option=$(use_with xinerama)
+}