summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-16 23:36:52 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-16 23:48:02 -0400
commit92bf2469af69f939144dca6ee386a2e62dc83bc6 (patch)
tree215165afc8d65bb0c1475403a06e350e7a1034c0
parentx11-wm/jwm: clean old (diff)
downloadgentoo-92bf2469.tar.gz
gentoo-92bf2469.tar.bz2
gentoo-92bf2469.zip
dev-python/pyatspi: Version bump to 2.38.1
* Add test dependency on gtk+3 (bug #764797) Closes: https://bugs.gentoo.org/764797 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-python/pyatspi/Manifest1
-rw-r--r--dev-python/pyatspi/pyatspi-2.38.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index f4a02a997de2..3912a10f292f 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1 +1,2 @@
DIST pyatspi-2.36.0.tar.xz 315076 BLAKE2B f3f92dafab68ce003e9d63f8ebf901ef834eafb1fab3ddd2051dcfb308b79d7ce6fc4d9187ed51f3af8bebad5e6ef2296c19215ee209ad37fe717f332af8d8f7 SHA512 709236fd992f570426043e32b201bdfee06bb28faa3d1237778f4069d3548b88b8336e53c0951359f5c7e2914b90f6f682ac58e33c84e32f360bdc32662800af
+DIST pyatspi-2.38.1.tar.xz 316724 BLAKE2B 59ca2569575f3d319d33972477ebc966670138df8cb6570ac260dd903f54df66fd12beeeee53e3380938e4571910b99ae2bf3f395776b16a73ac27f8fa023c49 SHA512 bf8f1ee9a6e00014a84e4329bb971bec8b4bc8f72c3905ca585ca20b1cf000b855965159fcc10871eb92e9808a6b41b5d793f3ab563ff0867f185279eedcd487
diff --git a/dev-python/pyatspi/pyatspi-2.38.1.ebuild b/dev-python/pyatspi/pyatspi-2.38.1.ebuild
new file mode 100644
index 000000000000..e1cb0d9edadb
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.38.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome2 python-r1 virtualx
+
+DESCRIPTION="Python client bindings for D-Bus AT-SPI"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+ test? ( x11-libs/gtk+:3 )
+"
+RDEPEND="${DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.34[introspection]
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure $(use_enable test tests)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir virtx dbus-run-session emake check
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installing
+
+ docinto examples
+ dodoc examples/*.py
+}