summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-04-15 11:05:57 -0400
committerKenton Groombridge <concord@gentoo.org>2023-04-15 11:05:57 -0400
commit92c63802bb4886bd9a96c41885836b5816e5762f (patch)
treee37ad76e3783eabc212e93c7a0e75fb736775877
parentsys-libs/libselinux: drop 3.4 (diff)
downloadgentoo-92c63802bb4886bd9a96c41885836b5816e5762f.tar.gz
gentoo-92c63802bb4886bd9a96c41885836b5816e5762f.tar.bz2
gentoo-92c63802bb4886bd9a96c41885836b5816e5762f.zip
sys-apps/checkpolicy: drop 3.4
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
-rw-r--r--sys-apps/checkpolicy/Manifest1
-rw-r--r--sys-apps/checkpolicy/checkpolicy-3.4.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/sys-apps/checkpolicy/Manifest b/sys-apps/checkpolicy/Manifest
index 3ce51e9cb737..d3279c23fc81 100644
--- a/sys-apps/checkpolicy/Manifest
+++ b/sys-apps/checkpolicy/Manifest
@@ -1,2 +1 @@
-DIST checkpolicy-3.4.tar.gz 69870 BLAKE2B 891033b1d9d50a3738bb779d014d2f04d6cc5450c6f84ed43246c95b0c808f347d65c0e51c7254041e13b1c555a7e1de5092abb4fc12fabb109be7ddaa090829 SHA512 e7f7a4e987af473fd7cda0e47539061a8cb2e65a6b930f4736c538eb319129b260a3f03d2f50863e73a275ee3d58c441c33f95c80ea2bff6157e37226be54b92
DIST checkpolicy-3.5.tar.gz 69904 BLAKE2B e02ccad07534568a1bbb612330018bbe486800ea40df20ed6f9dc38c88aff7f8858782a28ba7915a58c3bb384f180eb8da7a8fe97a92bcb9baa61eec18da6cbc SHA512 fcd490d865af3b4350c32c5dd9916f8406219841e1e255d8945c6dcc958535247aa27af5597a6988e19f11faea7beeabcb46e8ba2431112bb4aa5c7697bca529
diff --git a/sys-apps/checkpolicy/checkpolicy-3.4.ebuild b/sys-apps/checkpolicy/checkpolicy-3.4.ebuild
deleted file mode 100644
index 4de3914676df..000000000000
--- a/sys-apps/checkpolicy/checkpolicy-3.4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-MY_PV="${PV//_/-}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="SELinux policy compiler"
-HOMEPAGE="http://userspace.selinuxproject.org"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${P}/${PN}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~mips ~riscv x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug"
-
-DEPEND=">=sys-libs/libsepol-${PV}"
-BDEPEND="sys-devel/flex
- sys-devel/bison"
-
-RDEPEND=">=sys-libs/libsepol-${PV}"
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- YACC="bison -y" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
-}
-
-src_install() {
- default
-
- if use debug; then
- dobin "${S}/test/dismod"
- dobin "${S}/test/dispol"
- fi
-}
-
-pkg_postinst() {
- if ! tc-is-cross-compiler; then
- einfo "This checkpolicy can compile version `checkpolicy -V | cut -f 1 -d ' '` policy."
- fi
-}