summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-30 22:56:15 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-03-30 22:57:51 +0200
commit92d2a4887341427bacb8829676b2fa7ebd8b4ce8 (patch)
tree457272748225a60eff86586b91f505f904738ea4
parentnet-wireless/unifi: drop 7.0.23 (diff)
downloadgentoo-92d2a488.tar.gz
gentoo-92d2a488.tar.bz2
gentoo-92d2a488.zip
dev-lua/luaexpat: add 1.4.0
Closes: https://bugs.gentoo.org/834411 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luaexpat/Manifest1
-rw-r--r--dev-lua/luaexpat/luaexpat-1.4.0.ebuild73
-rw-r--r--dev-lua/luaexpat/metadata.xml4
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-lua/luaexpat/Manifest b/dev-lua/luaexpat/Manifest
index 5913ec63d907..5449c7b27685 100644
--- a/dev-lua/luaexpat/Manifest
+++ b/dev-lua/luaexpat/Manifest
@@ -1 +1,2 @@
DIST luaexpat-1.3.0.tar.gz 29567 BLAKE2B 176cb107e6047b15338ff45751af82389920e4210d40bd0b4400e549130a4983c843f7a64bb7b2fba37e36eb592e850d06efe196f8e837e79e50c8d135dbe763 SHA512 91884653310e2dc89ade6d1653875ac8607640a21853d3ccb1fd0f833812e41981fad5c40101732ec249104d2c50c9a332208d1e44423b8428065a223c60b4ae
+DIST luaexpat-1.4.0.tar.gz 51890 BLAKE2B 6e2cda190e7b2ebe2bda64398a447155df3ccdb83f1b4ff78aead981c38cf6705f896ba31ac0d557ec55f750919b6b2b07205c533339d7aa8e0f88ee6b0991fd SHA512 ba1a98267757ec5f2464b8d5e903f69102ca991c4034939d02d871d014463a8e29815d1294edc7fa3a1c4b679c5e42fdc1a19b2a1c1654ed1f382f779a213375
diff --git a/dev-lua/luaexpat/luaexpat-1.4.0.ebuild b/dev-lua/luaexpat/luaexpat-1.4.0.ebuild
new file mode 100644
index 000000000000..b0c2791bf0e6
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-1.4.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A SAX XML parser based on the Expat library"
+HOMEPAGE="https://github.com/lunarmodules/luaexpat"
+SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/expat
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( "docs/." )
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-O2//g' -i Makefile || die
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LUA_INC=$(lua_get_CFLAGS)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "DESTDIR=${ED}"
+ "LUA_CDIR=$(lua_get_cmod_dir)"
+ "LUA_INC=$(lua_get_include_dir)"
+ "LUA_LDIR=$(lua_get_lmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}
diff --git a/dev-lua/luaexpat/metadata.xml b/dev-lua/luaexpat/metadata.xml
index a9d447e11be2..7ec4c4086c74 100644
--- a/dev-lua/luaexpat/metadata.xml
+++ b/dev-lua/luaexpat/metadata.xml
@@ -13,4 +13,8 @@
<email>conikost@gentoo.org</email>
<name>Conrad Kostecki</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://github.com/lunarmodules/luaexpat/issues</bugs-to>
+ <remote-id type="github">luaexpat/issues</remote-id>
+ </upstream>
</pkgmetadata>