summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-17 09:24:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-17 10:30:59 +0200
commit92e35f57a75f949057072b059cf3c81fd2c14759 (patch)
tree3454c18eda75c55aa0bcc0e6a0acb301c42b9e67
parentdev-python/botocore: Bump to 1.21.43 (diff)
downloadgentoo-92e35f57.tar.gz
gentoo-92e35f57.tar.bz2
gentoo-92e35f57.zip
dev-python/boto3: Bump to 1.18.43
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.43.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 89b7e1d63c73..e549180188d7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.18.28.tar.gz 406268 BLAKE2B 1379f65f46f287a541b098b3ae183bc7d0a6c40
DIST boto3-1.18.40.tar.gz 412065 BLAKE2B c548c6a1f5cfac3d304384b56882943201c45f3515bcd3804b90656966ba5ada0bfd5130fef34d8ad1466aad8a45166a9e35706d4ea53e9eb4ca1fcfae7172f4 SHA512 95e0c6ea5a9741657d801b1feab1ac813b653becba442d83673168d029635928e031386c7147ce28a9407acda4b593fc32b0a4f6ff1761f4b8d903b585220cd5
DIST boto3-1.18.41.tar.gz 412328 BLAKE2B 134ec70addcb9748d255b86d9e12dd380094a6a82c1d79ea9772dcc59e6eaac95a4337a1980d4791f856bd9a4d84b2f0a79b00b8b7f5a2e57384eca95a4090f5 SHA512 a7d0093083a6dae9a9ee8ad183027adc5d1f4cde05f244f126af022c77df457c0810626fe9ce5baf6fbc9e8d9ec2f8086bf95587d4f80b63c47bf4ef210bf61a
DIST boto3-1.18.42.tar.gz 412699 BLAKE2B d03c4afe357def827e9169ced8b17f92caf79b8291edd5045629e1b8ee697014764caf3135910d9a0862380a94fbaabd1863535c0aad21fd1eca2b0d3e306ac2 SHA512 aae080862a3b30e23407cde6ced8a48522421be40f9eb192647f6ed2693ce6655576dd0705a998469274ba9ef74d24d51c31003798fc4f0856c417491aeab30b
+DIST boto3-1.18.43.tar.gz 413685 BLAKE2B 1733a75e17fabdd9941874fd7dfec735cde8702e4df07e5f3c293a9cd83207ae26f7adfc7caeb4913d2fc0d114c4738870b93053ce3e2485f9b4bc3286dabad1 SHA512 5191276feff196503cbd21a44bfd205737ed2c150071037d76198b164c56549b34f36266768f3e5346add393d6c25ad13daf6f6daf74217841d27e305c20c3f1
diff --git a/dev-python/boto3/boto3-1.18.43.ebuild b/dev-python/boto3/boto3-1.18.43.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.43.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}