summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuigi 'Comio' Mantellini <luigi.mantellini@gmail.com>2017-12-15 09:00:17 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-18 22:59:22 +0100
commit9315ce598157d90d7543dd9fdd478edf45b90f26 (patch)
tree27d8a109001da4cf449713229fb8bcbdde107753
parentnet-firewall/shorewall: Rev bump to fix >=sys-apps/iproute2-4.13.0 support (diff)
downloadgentoo-9315ce598157d90d7543dd9fdd478edf45b90f26.tar.gz
gentoo-9315ce598157d90d7543dd9fdd478edf45b90f26.tar.bz2
gentoo-9315ce598157d90d7543dd9fdd478edf45b90f26.zip
dev-python/node-semver: version bump to 0.2.0.
Closes: https://bugs.gentoo.org/641098 Closes: https://github.com/gentoo/gentoo/pull/6553
-rw-r--r--dev-python/node-semver/Manifest1
-rw-r--r--dev-python/node-semver/node-semver-0.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/node-semver/Manifest b/dev-python/node-semver/Manifest
index 2168aab669ef..a913a140bb3a 100644
--- a/dev-python/node-semver/Manifest
+++ b/dev-python/node-semver/Manifest
@@ -1 +1,2 @@
DIST node-semver-0.1.1.tar.gz 18338 BLAKE2B cfb9c74cb3cf84725de7de5a97766616f0327f7db0f91687f4448fca8d3f47505060f0580bc27bd0c7d53c160ccda29159f07345949d1132a12cff410ab08fcf SHA512 f652a69330907722d1e6449f237ae6c006a11c48f49b450d390700704309672573add77c103fc53d052014e751949348b344b001acf85ae6668e504811a1d198
+DIST node-semver-0.2.0.tar.gz 10236 BLAKE2B f4f48761a0086b8a2e79307427b4dc93954362452f653042582024cee593b4b7fefb1a14d3d4ea6832255209b054c9bdb05b02cb101af1e359a1266c472c5149 SHA512 7c636d94a262723c5e50123433c9c7af38424c46711c1b8e001931b242fc9703a084a0426b75e6884104a4adc6104a298355bf3c1604b9cae0ddab7d5f11b430
diff --git a/dev-python/node-semver/node-semver-0.2.0.ebuild b/dev-python/node-semver/node-semver-0.2.0.ebuild
new file mode 100644
index 000000000000..f51fb5a27e36
--- /dev/null
+++ b/dev-python/node-semver/node-semver-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python version of node-semver, the semantic versioner for npm"
+HOMEPAGE="
+ https://pypi.python.org/pypi/node-semver
+ https://github.com/podhmo/python-semver
+ https://github.com/npm/node-semver"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die
+}