summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-05-05 12:52:25 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-05-05 12:56:38 +0200
commit935064cc336cabb6b8e22fc9b97f13c81c5a1767 (patch)
treed13facc72099075d6c813c6445ad9864ac8c1e04
parentmail-filter/rspamd: Bump to version 1.5.7 (diff)
downloadgentoo-935064cc.tar.gz
gentoo-935064cc.tar.bz2
gentoo-935064cc.zip
dev-libs/libfastjson: Bump to v0.99.5
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-libs/libfastjson/Manifest1
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libfastjson/Manifest b/dev-libs/libfastjson/Manifest
index 323619a1dcf0..1e4fb84ac80b 100644
--- a/dev-libs/libfastjson/Manifest
+++ b/dev-libs/libfastjson/Manifest
@@ -1,2 +1,3 @@
DIST libfastjson-0.99.2.tar.gz 366602 SHA256 6ff053d455243a81014f37b4d81c746d9b8d40256a56326c3a7921c8bf458dfd SHA512 4b57697cbb901bc12a26d98c3d6df998aba373d4f38339189c9bd3e5a32777fa4796039fe82581337e576fa93c6deb87759eba04326134f587064c82e1b3daaf WHIRLPOOL 56010125b4ba905aba3fa7ad69faf38237426c1ef5cbaad90458fe31e96b86719d2766d2099928dc22aa7d98a64d079a3bd9de31702b28547d1f1d416170d487
DIST libfastjson-0.99.4.tar.gz 424989 SHA256 6339a67e680a8f6a6a0c179971118489cc14ec73bb1542b591c38f58d760034c SHA512 b38f01469021093f21b43550e7574d2bad7b57a28b62f27cb1d2a57e33d2cb29208d20d978bdebe5a82a9736dfcfd7ec0a0fa945762702f4389d69850c2cfeb3 WHIRLPOOL 15898787b20b13648cfc19496da69e86223400fd9e62cb9ce4362364cf5f6d7df32f54a79e4d225bedcdf91cdb0c9231a3e2a6e63d7366b3290624aaf7854dc7
+DIST libfastjson-0.99.5.tar.gz 431298 SHA256 8aecdc111da2beebc09e99e2b51e13b70f219c5a095c38db953a75fde51779e9 SHA512 5fa28c49465092865b60c7e671747d72ae1a102a375b5edae378a4e82b023b3944dcd235ca247ea6f24186d34e3caddd1d0abb7d8d0ccae295b80a870c01582e WHIRLPOOL 7f9f5abb44c6edf8f043b34157786eb5e2b2ef4361e38f94fbdf171fc763313cef0633ca37644c53f97ccf84444daf67ec821225c2140430076447b6dbb1db93
diff --git a/dev-libs/libfastjson/libfastjson-0.99.5.ebuild b/dev-libs/libfastjson/libfastjson-0.99.5.ebuild
new file mode 100644
index 000000000000..ef28437bd5b6
--- /dev/null
+++ b/dev-libs/libfastjson/libfastjson-0.99.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fork of the json-c library, which is optimized for liblognorm processing"
+HOMEPAGE="http://www.rsyslog.com/tag/libfastjson/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0/4.1.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-devel/autoconf-archive-2015.02.04"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ $(use_enable static-libs static)
+ --disable-rdrand
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog )
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}