summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 06:46:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 07:05:27 +0200
commit93623d4e82f07aac415ddf7b6978bd407646cf16 (patch)
tree741f4e6926115e884d8550cc7b24e7a74915e576
parentdev-python/xlsxwriter: Bump to 3.1.7 (diff)
downloadgentoo-93623d4e82f07aac415ddf7b6978bd407646cf16.tar.gz
gentoo-93623d4e82f07aac415ddf7b6978bd407646cf16.tar.bz2
gentoo-93623d4e82f07aac415ddf7b6978bd407646cf16.zip
dev-python/python-lsp-server: Bump to 1.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-lsp-server/Manifest1
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.8.2.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index 79bd52477678..32c491a730b8 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,3 +1,4 @@
DIST python-lsp-server-1.7.4.tar.gz 97864 BLAKE2B 9832298391d72bf2f035f388694a7879d66546ead5a36837220cb3af5d8181eba198c04dd82747cba75f0478d256b001476c24b02bc679fc07cb41c7aedb0e66 SHA512 7aa96de6e51548e2854b55690698fe6c7bda60103c11ad5982df611c65569cec1ab13691727c92ec47d9ac44c34f233f872211a41041ea0969223e10e87d7e08
DIST python-lsp-server-1.8.0.tar.gz 105548 BLAKE2B aa7f714bbc7e88d68224f9a51c3c811168ade36afce02fcdf95d3ffef55f7efc964aea6fb3c26bc88c3439744928f70914c136987c89a8bd146a2f54df579ead SHA512 b8050037e313261b653f0df170762126886ceef780d7ca35651c79967270d78d9930e464ccecc71a40ceee10b0265fd262d200e1e38c50ce04490ab364bc8389
DIST python-lsp-server-1.8.1.tar.gz 106979 BLAKE2B 3d71de40b4fff5a0e50d1e16fb1aab330c90ddc68d255f212c8ec9a1c2cc5afcbafaa9d288f938d22b824852f6ca231d48f031df3dcc7e9d97699767b3548788 SHA512 f26e836013df9ddee05f17e7629bf7abfab96aae6fc4eba9d565203b324f6e3ac3e02cbcc1bd1b9ad8a4e0628d58476797bd55564e0307a53946df7a934df11b
+DIST python-lsp-server-1.8.2.tar.gz 107104 BLAKE2B 8a525e25f94c97cef23e6e9fad4ef9d7e5e0afaf1efdac9f5b98c84bc634ffaed2c19ebed80113a771a30b777285db166996ae25a3d34963e75909e183e082dc SHA512 4cfed043c69a6a390b27299d1e8e53c9ad0184e72b98503e4b3314b7104841a4f3667988e62dcaa88c54b166a1f8549e5b56a70fa69a33068bda5dc49299d642
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.8.2.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.8.2.ebuild
new file mode 100644
index 000000000000..f94cd79aa7da
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.8.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-server/
+ https://pypi.org/project/python-lsp-server/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="all-plugins"
+
+RDEPEND="
+ dev-python/docstring-to-markdown[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.1.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ >=dev-python/autopep8-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/yapf-0.33.0[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/yapf-0.33.0[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '/addopts =/d' pyproject.toml || die
+ # unpin all the deps
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by presence of pathlib2
+ 'test/plugins/test_autoimport.py'
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}