summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-20 20:32:31 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-20 20:32:47 +0200
commit9370782a0a8d2144dab584195afcd77c7a3b11c9 (patch)
tree6dd983c4f3eb02629eb93a665d2fd114c648bc36
parentprofiles/arch/ia64: mask USE=openexr (diff)
downloadgentoo-9370782a0a8d2144dab584195afcd77c7a3b11c9.tar.gz
gentoo-9370782a0a8d2144dab584195afcd77c7a3b11c9.tar.bz2
gentoo-9370782a0a8d2144dab584195afcd77c7a3b11c9.zip
net-p2p/kubo: drop 0.20.0, 0.22.0, 0.25.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--net-p2p/kubo/Manifest3
-rw-r--r--net-p2p/kubo/kubo-0.20.0.ebuild70
-rw-r--r--net-p2p/kubo/kubo-0.22.0.ebuild72
-rw-r--r--net-p2p/kubo/kubo-0.25.0.ebuild72
4 files changed, 0 insertions, 217 deletions
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index ae0d966d10e1..275a016f042f 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -1,4 +1 @@
-DIST kubo-0.20.0.tar.gz 15476743 BLAKE2B 8b7e58f18c1342981f575545c6e11a167df240bb0d6d0712bcb3fd6a0aa7f84a6737af06d2ae89fe998ee715be5c0e0c39f4ce83685ae238008c46f48c6cf7a1 SHA512 5231efce18dbb6491fa6665db8d1522efcb2d7278203259714b77d655060765922e9076addb1de3e10950c2c7aa3c9e24e2114879c3e4ce1fceef69755b12eaf
-DIST kubo-0.22.0.tar.gz 15681418 BLAKE2B 059c6b34a8188ad2add2ecb1cd8f69d755388d9c74c58ad5c2e95459101aa77397ad16e92b72ffe703f0dc2f62b04573fdf9da065aaee003623c6038601370c7 SHA512 08fff4a53286e106ecebeb2bee6f0f0154e8f75029f9dacf5c5e99f23d27c8243adb8cf69bea7da1df0e849bf325f18516ed6c18a5454623da2530a0f3810a32
-DIST kubo-0.25.0.tar.gz 16346357 BLAKE2B d9871cccb88a00929eedbc3322926683275786328dc70581208d3b59d59e34c3c8374e3f5194c163dc3517a848675671573429ca72bc41e7ca00d38a40c3b2db SHA512 ec089317ef7bea0d3dbc723e601e5b5e4dcd030ad5edc11a6e4fdb4f2b33be771e2e54189af260b11a6259a0a8108eabb7c09d224ae9711642430926586f2f95
DIST kubo-0.26.0.tar.gz 16129891 BLAKE2B 199e3fb3d7982eb3bca35c7139a15f4c4f32a54bde2c9ae2e5b594524668d146296001ccfb29d1ded5eec0e82a02b4e16a4bbb7a82bcc4787ee06820f02d4687 SHA512 21bcfd605d0aa0b55afafa5c717b6b0f8c657722a207ae0cb901815b7881266ae528acc85d74e70f5fafec9407c68cd5dcb2e02ab9fbe61c05f648888e15e0e5
diff --git a/net-p2p/kubo/kubo-0.20.0.ebuild b/net-p2p/kubo/kubo-0.20.0.ebuild
deleted file mode 100644
index ba92ae6a0382..000000000000
--- a/net-p2p/kubo/kubo-0.20.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 go-module systemd
-
-DESCRIPTION="Main implementation of IPFS"
-HOMEPAGE="https://ipfs.io/ https://github.com/ipfs/kubo/"
-SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-DEPEND="
- acct-group/ipfs
- acct-user/ipfs
- sys-fs/fuse:0
-"
-RDEPEND="${DEPEND}"
-# <go-1.21 for bug #912149
-BDEPEND="<dev-lang/go-1.21"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
-
-S="${WORKDIR}"
-
-src_compile() {
- local mygoargs
- mygoargs=(
- -tags release
- )
-
- ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
- ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
-
- IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
-}
-
-src_test() {
- ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
-}
-
-src_install() {
- dobin ipfs
- dobin ipfswatch
- newbashcomp ipfs-completion.bash ipfs
- einstalldocs
-
- systemd_dounit "${FILESDIR}/ipfs.service"
- systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
-
- newinitd "${FILESDIR}/ipfs.init" ipfs
- newconfd "${FILESDIR}/ipfs.confd" ipfs
-
- keepdir /var/log/ipfs
- fowners -R ipfs:ipfs /var/log/ipfs
-}
-
-pkg_postinst() {
- elog 'To be able to use the ipfs service you will need to create the ipfs repository'
- elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
- elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
-
- # See https://bugs.gentoo.org/838238
- ewarn 'In case kubo CPU usage is too high run the next workaround'
- ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
- ewarn 'Be aware that this will make your node less visible to other peers'
-}
diff --git a/net-p2p/kubo/kubo-0.22.0.ebuild b/net-p2p/kubo/kubo-0.22.0.ebuild
deleted file mode 100644
index 7ecb3b7e9102..000000000000
--- a/net-p2p/kubo/kubo-0.22.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module shell-completion systemd
-
-DESCRIPTION="Main implementation of IPFS"
-HOMEPAGE="https://ipfs.io/ https://github.com/ipfs/kubo/"
-SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- acct-group/ipfs
- acct-user/ipfs
- sys-fs/fuse:0
-"
-RDEPEND="${DEPEND}"
-# <go-1.21 for bug #912149
-BDEPEND="<dev-lang/go-1.21"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
-
-S="${WORKDIR}"
-
-src_compile() {
- local mygoargs
- mygoargs=(
- -tags release
- )
-
- ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
- ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
-
- IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
- IPFS_PATH="" ./ipfs commands completion fish > ipfs-completion.fish || die
-}
-
-src_test() {
- ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
-}
-
-src_install() {
- dobin ipfs
- dobin ipfswatch
- newbashcomp ipfs-completion.bash ipfs
- newfishcomp ipfs-completion.fish ipfs
- einstalldocs
-
- systemd_dounit "${FILESDIR}/ipfs.service"
- systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
-
- newinitd "${FILESDIR}/ipfs.init" ipfs
- newconfd "${FILESDIR}/ipfs.confd" ipfs
-
- keepdir /var/log/ipfs
- fowners -R ipfs:ipfs /var/log/ipfs
-}
-
-pkg_postinst() {
- elog 'To be able to use the ipfs service you will need to create the ipfs repository'
- elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
- elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
-
- # See https://bugs.gentoo.org/838238
- ewarn 'In case kubo CPU usage is too high run the next workaround'
- ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
- ewarn 'Be aware that this will make your node less visible to other peers'
-}
diff --git a/net-p2p/kubo/kubo-0.25.0.ebuild b/net-p2p/kubo/kubo-0.25.0.ebuild
deleted file mode 100644
index 5eb80133d072..000000000000
--- a/net-p2p/kubo/kubo-0.25.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module shell-completion systemd
-
-DESCRIPTION="Main implementation of IPFS"
-HOMEPAGE="https://ipfs.io/ https://github.com/ipfs/kubo/"
-SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- acct-group/ipfs
- acct-user/ipfs
- sys-fs/fuse:0
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
-
-S="${WORKDIR}"
-
-src_compile() {
- local mygoargs
- mygoargs=(
- -tags release
- )
-
- ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
- ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
-
- IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
- IPFS_PATH="" ./ipfs commands completion fish > ipfs-completion.fish || die
- IPFS_PATH="" ./ipfs commands completion zsh > ipfs-completion.zsh || die
-}
-
-src_test() {
- ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
-}
-
-src_install() {
- dobin ipfs
- dobin ipfswatch
- newbashcomp ipfs-completion.bash ipfs
- newfishcomp ipfs-completion.fish ipfs
- newzshcomp ipfs-completion.zsh _ipfs
- einstalldocs
-
- systemd_dounit "${FILESDIR}/ipfs.service"
- systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
-
- newinitd "${FILESDIR}/ipfs.init" ipfs
- newconfd "${FILESDIR}/ipfs.confd" ipfs
-
- keepdir /var/log/ipfs
- fowners -R ipfs:ipfs /var/log/ipfs
-}
-
-pkg_postinst() {
- elog 'To be able to use the ipfs service you will need to create the ipfs repository'
- elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
- elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
-
- # See https://bugs.gentoo.org/838238
- ewarn 'In case kubo CPU usage is too high run the next workaround'
- ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
- ewarn 'Be aware that this will make your node less visible to other peers'
-}