summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-10-31 07:04:05 +0100
committerJeroen Roovers <jer@gentoo.org>2015-10-31 07:04:05 +0100
commit9376ba26050df7fee4e8aa28bf53f90e47169ab0 (patch)
tree9b97f2d515980194112fdb946a6f8d92f1d35943
parentnet-analyzer/argus: Old. (diff)
downloadgentoo-9376ba26.tar.gz
gentoo-9376ba26.tar.bz2
gentoo-9376ba26.zip
net-analyzer/argus: Version bump.
Package-Manager: portage-2.2.23
-rw-r--r--net-analyzer/argus/Manifest1
-rw-r--r--net-analyzer/argus/argus-3.0.8.2_rc2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-analyzer/argus/Manifest b/net-analyzer/argus/Manifest
index 1e8051ffd6d8..94d556222984 100644
--- a/net-analyzer/argus/Manifest
+++ b/net-analyzer/argus/Manifest
@@ -1 +1,2 @@
DIST argus-3.0.8.1.tar.gz 523375 SHA256 1fb921104c8bd843fb9f5a1c32b57b20bfe8cd8a103b3f1d9bb686b9e6c490a4 SHA512 d96332849df7ce2297aa0d81a9f22c12763d04b2936ffaffc0e4b1942535846cfbc41dadf28791eb88d1ffd0429bdc280d16dff44369c415c713064849b158f7 WHIRLPOOL 2c9495d585c2297b3f9951e74a8fd28840941be6b298c0178d44801242d1abda4bd08f9469e2dd1a4b802735611c9ff82bc028d838628b1ccb184ba80d5dc529
+DIST argus-3.0.8.2.rc.2.tar.gz 525053 SHA256 a499154248fd32d0809599b78e5078353a97edbbf595ad48701c9646c2c5515f SHA512 c8272ae80f66114a4a83c365d9257d90ffe944cb648112ba9d756ad235d3d7231d09fe9de2dc31f2d72d5070e3e932b8de49661371806c5e1b21d7aea0aad3b1 WHIRLPOOL 80fc3d7c0c96fee1243903119a3d3d6391da6b42e0c3610b817d205d65776f6df93bd99e7a8900d3422dab48a75da5839efd4284cb6abada7bef6989534138b6
diff --git a/net-analyzer/argus/argus-3.0.8.2_rc2.ebuild b/net-analyzer/argus/argus-3.0.8.2_rc2.ebuild
new file mode 100644
index 000000000000..e767e08860de
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.8.2_rc2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils user
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="${HOMEPAGE}dev/${P/_rc/.rc.}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug sasl tcpd"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/zlib
+ sasl? ( dev-libs/cyrus-sasl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+S=${WORKDIR}/${P/_rc/.rc.}
+
+src_prepare() {
+ find . -type f -execdir chmod +w {} \; #561360
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.8.1-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.5-Makefile.patch \
+ "${FILESDIR}"/${PN}-3.0.7.3-DLT_IPNET.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers) $(use_with sasl)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/*.5 man/man8/*.8
+
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ keepdir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that the init script will fail to work."
+}