summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-08-13 03:50:02 +0300
committerStefan Strogin <steils@gentoo.org>2020-08-13 03:52:42 +0300
commit939c523fdea7b0cdbe25f7f4f438e299d63c6e1e (patch)
tree67481ff0925589122fd4ba38d2184a39a58aa928
parentdev-perl/Mojolicious: Bump to version 8.300.0 (diff)
downloadgentoo-939c523fdea7b0cdbe25f7f4f438e299d63c6e1e.tar.gz
gentoo-939c523fdea7b0cdbe25f7f4f438e299d63c6e1e.tar.bz2
gentoo-939c523fdea7b0cdbe25f7f4f438e299d63c6e1e.zip
media-video/avidemux: add i18n tarball to fix compilation
Since https://github.com/mean00/avidemux2/commit/0100e4b4 "[i18n] Move TS.cmake to submodule" a git submodule i18n is used get translation files which are moved to a separate repository. Download the release tarball with the translation files and unpack them to the i18n submodule directory, where cmake expects it. Closes: https://bugs.gentoo.org/736820 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--media-video/avidemux/Manifest1
-rw-r--r--media-video/avidemux/avidemux-2.7.6-r1.ebuild (renamed from media-video/avidemux/avidemux-2.7.6.ebuild)8
2 files changed, 8 insertions, 1 deletions
diff --git a/media-video/avidemux/Manifest b/media-video/avidemux/Manifest
index 20c2b9ff2f29..8b053b938cb5 100644
--- a/media-video/avidemux/Manifest
+++ b/media-video/avidemux/Manifest
@@ -1,2 +1,3 @@
DIST avidemux-2.7.4.tar.gz 23815808 BLAKE2B 3a7206f04f568f28dd4d5116c580dd780b057a59e94dd61a2abe5dadfa557291a0c50f917ad1926f9f9a82d01af065c06138f954320e2d9c174fda7583a6b265 SHA512 36d857837cd6a74039a414df16367cd8cbf615173bcc531e57dc0dbfc2e002b1c0c4a80cef73a0d8f25d305deca809af0b5cbcdbad8c311324fa2e64381fd10b
DIST avidemux-2.7.6.tar.gz 21963753 BLAKE2B 6ca343f90c37844ebfd61123badccefb7327cbf500723c031257cf26500a5b6d98955568c2a9c0d182af68f162e878459a51e6049485937f9b01b4439b32e5e0 SHA512 bc60c733168d40d5b39cc7dd1f74b3f1315e9727302478ef1621e18748bad3400bcfd4d5199862c3093ad9df51385b6b2a96f0f8fedf9bf1c00060327545fb0f
+DIST avidemux-i18n-2.7.6.tar.gz 2268693 BLAKE2B dedf6d015e6bbd58f432e05e72c4d8d175ce4f5567331b5e51e7a14d2a8180e92211efc172a4d7001a2947f46c2e910a485d42970b99df05c1ba12002974cfbf SHA512 26ada29c4b7c23739ddcc4ca1dc9819bbc64fa2b6472fd7ff5706905dbd9b382e7a7d69ba78f72afa6f3db55cf3c5373a5e2d244f1cf189aeb187984dd1f4187
diff --git a/media-video/avidemux/avidemux-2.7.6.ebuild b/media-video/avidemux/avidemux-2.7.6-r1.ebuild
index 8808e2507b90..33583b343b9e 100644
--- a/media-video/avidemux/avidemux-2.7.6.ebuild
+++ b/media-video/avidemux/avidemux-2.7.6-r1.ebuild
@@ -8,7 +8,8 @@ inherit cmake desktop qmake-utils xdg
DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
HOMEPAGE="http://fixounet.free.fr/avidemux"
-SRC_URI="https://github.com/mean00/avidemux2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/mean00/avidemux2/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/mean00/avidemux2_i18n/archive/${PV}.tar.gz -> ${PN}-i18n-${PV}.tar.gz"
# Multiple licenses because of all the bundled stuff.
LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
@@ -39,6 +40,11 @@ PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt5?]"
S="${WORKDIR}/avidemux2-${PV}"
+src_unpack() {
+ default
+ mv -f -T avidemux2_i18n-${PV} "${S}"/avidemux/qt4/i18n >/dev/null || die
+}
+
src_prepare() {
eapply "${FILESDIR}"/${PN}-2.7.4-qt-5.15.patch