summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-07 00:06:27 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-07 00:08:32 -0500
commit93aa4938c198262facb58c264846571b3894c32e (patch)
tree207bda0b93d2bde65f33ff9693de6a7d165d5f85
parentapp-admin/fam: fix build w/newer glibc #580702 (diff)
downloadgentoo-93aa4938c198262facb58c264846571b3894c32e.tar.gz
gentoo-93aa4938c198262facb58c264846571b3894c32e.tar.bz2
gentoo-93aa4938c198262facb58c264846571b3894c32e.zip
app-admin/fam: make out of tree builds work to avoid pointless source tree copies
-rw-r--r--app-admin/fam/fam-2.7.0-r7.ebuild4
-rw-r--r--app-admin/fam/files/fam-2.7.0-out-of-tree.patch13
2 files changed, 15 insertions, 2 deletions
diff --git a/app-admin/fam/fam-2.7.0-r7.ebuild b/app-admin/fam/fam-2.7.0-r7.ebuild
index 166061bae005..179ada610e01 100644
--- a/app-admin/fam/fam-2.7.0-r7.ebuild
+++ b/app-admin/fam/fam-2.7.0-r7.ebuild
@@ -28,14 +28,14 @@ src_prepare() {
EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch "${S}"/${P}/debian/patches
sed -i configure.ac -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ epatch "${FILESDIR}"/${P}-out-of-tree.patch
epatch "${FILESDIR}"/${P}-sysmacros.patch #580702
eautoreconf
- multilib_copy_sources
}
multilib_src_configure() {
- econf $(use_enable static-libs static)
+ ECONF_SOURCE=${S} econf $(use_enable static-libs static)
# These are thrown away later
if ! multilib_is_native_abi ; then
diff --git a/app-admin/fam/files/fam-2.7.0-out-of-tree.patch b/app-admin/fam/files/fam-2.7.0-out-of-tree.patch
new file mode 100644
index 000000000000..51fdadf38fe6
--- /dev/null
+++ b/app-admin/fam/files/fam-2.7.0-out-of-tree.patch
@@ -0,0 +1,13 @@
+fix out of tree builds
+
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -7,7 +7,7 @@
+ Client.h \
+ fam.c++
+
+-libfam_la_LDFLAGS = -export-symbols fam.sym
++libfam_la_LDFLAGS = -export-symbols $(srcdir)/fam.sym
+ libfam_la_LIBADD = -lstdc++
+
+ EXTRA_DIST = fam.sym