summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-02-07 22:29:20 +0100
committerSebastian Pipping <sping@gentoo.org>2020-02-07 22:29:20 +0100
commit93ab64a4f3c94a316effa410922a5fbd82ce8b15 (patch)
tree424229fc04e757b793ffbfc2fa4550f22b41e5fb
parentapp-editors/nano: Bump to version 4.8 (diff)
downloadgentoo-93ab64a4.tar.gz
gentoo-93ab64a4.tar.bz2
gentoo-93ab64a4.zip
www-apps/nikola: EAPI 7 + doman fix
Closes: https://bugs.gentoo.org/619974 Closes: https://github.com/gentoo/gentoo/pull/14535 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
-rw-r--r--www-apps/nikola/nikola-7.8.15-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/www-apps/nikola/nikola-7.8.15-r1.ebuild b/www-apps/nikola/nikola-7.8.15-r1.ebuild
index c989d8059c4f..f7d523787787 100644
--- a/www-apps/nikola/nikola-7.8.15-r1.ebuild
+++ b/www-apps/nikola/nikola-7.8.15-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -32,7 +33,6 @@ RDEPEND="${DEPEND}
>=dev-python/pygments-1.6[${PYTHON_USEDEP}]
>=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.4[${PYTHON_USEDEP}]
- >=dev-python/setuptools-20.3[${PYTHON_USEDEP}]
>=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
>=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
>=dev-python/yapsy-1.11.223[${PYTHON_USEDEP}]
@@ -58,6 +58,5 @@ src_install() {
rm -rv "${D}/usr/share/doc/${PN}" || die
dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
- gunzip "docs/man/${PN}.1.gz" || die
- doman "docs/man/${PN}.1"
+ gunzip "${D}/usr/share/man/man1/${PN}.1.gz" || die
}