summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Camera <dennis.camera+gentoo@riiengineering.ch>2024-03-27 12:08:45 +0100
committerSam James <sam@gentoo.org>2024-04-30 07:39:08 +0100
commit93b5d2f23960fd5b8b1ed13e056383b9a907940f (patch)
tree00fab38413face3d181f704386d58ca97d17bda4
parentsys-libs/ldb: fix redefinition of uintptr_t in bundled cmocka library (diff)
downloadgentoo-93b5d2f23960fd5b8b1ed13e056383b9a907940f.tar.gz
gentoo-93b5d2f23960fd5b8b1ed13e056383b9a907940f.tar.bz2
gentoo-93b5d2f23960fd5b8b1ed13e056383b9a907940f.zip
net-fs/samba: fix redefinition of uintptr_t in bundled cmocka library
Build failed with musl libc: In file included from ../../third_party/cmocka/cmocka.c:61: ../../third_party/cmocka/cmocka.h:127:28: error: conflicting types for 'uintptr_t'; have 'unsigned int' 127 | typedef unsigned int uintptr_t; | ^~~~~~~~~ In file included from /usr/include/stdint.h:20, from /usr/include/inttypes.h:9, from ../../third_party/cmocka/cmocka.c:27: /usr/include/bits/alltypes.h:47:24: note: previous declaration of 'uintptr_t' with type 'uintptr_t' {aka 'long unsigned int'} 47 | typedef unsigned _Addr uintptr_t; | ^~~~~~~~~ Signed-off-by: Dennis Camera <dennis.camera+gentoo@riiengineering.ch> Closes: https://github.com/gentoo/gentoo/pull/35945 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-fs/samba/files/cmocka-config_h.patch23
-rw-r--r--net-fs/samba/samba-4.18.10.ebuild1
-rw-r--r--net-fs/samba/samba-4.18.8.ebuild1
-rw-r--r--net-fs/samba/samba-4.18.9.ebuild1
-rw-r--r--net-fs/samba/samba-4.19.4.ebuild1
5 files changed, 27 insertions, 0 deletions
diff --git a/net-fs/samba/files/cmocka-config_h.patch b/net-fs/samba/files/cmocka-config_h.patch
new file mode 100644
index 000000000000..124928450cd6
--- /dev/null
+++ b/net-fs/samba/files/cmocka-config_h.patch
@@ -0,0 +1,23 @@
+--- ./third_party/cmocka/cmocka.h.orig 2024-03-26 10:23:03.378410042 +0100
++++ ./third_party/cmocka/cmocka.h 2024-03-26 10:24:51.526922405 +0100
+@@ -14,6 +14,11 @@
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
++
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #ifndef CMOCKA_H_
+ #define CMOCKA_H_
+
+@@ -111,7 +114,7 @@
+ ((LargestIntegralType)(value))
+
+ /* Smallest integral type capable of holding a pointer. */
+-#if !defined(_UINTPTR_T) && !defined(_UINTPTR_T_DEFINED)
++#if !defined(HAVE_UINTPTR_T) && !defined(_UINTPTR_T) && !defined(_UINTPTR_T_DEFINED) && !defined(__DEFINED_uintptr_t)
+ # if defined(_WIN32)
+ /* WIN32 is an ILP32 platform */
+ typedef unsigned int uintptr_t;
diff --git a/net-fs/samba/samba-4.18.10.ebuild b/net-fs/samba/samba-4.18.10.ebuild
index aad41632fada..be5091996562 100644
--- a/net-fs/samba/samba-4.18.10.ebuild
+++ b/net-fs/samba/samba-4.18.10.ebuild
@@ -146,6 +146,7 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${FILESDIR}"/${PN}-4.18.4-pam.patch
"${FILESDIR}"/ldb-2.5.2-skip-wav-tevent-check.patch
+ "${FILESDIR}"/cmocka-config_h.patch
)
CONFDIR="${FILESDIR}/4.4"
diff --git a/net-fs/samba/samba-4.18.8.ebuild b/net-fs/samba/samba-4.18.8.ebuild
index 8135362ec56e..6d1877fa6e7b 100644
--- a/net-fs/samba/samba-4.18.8.ebuild
+++ b/net-fs/samba/samba-4.18.8.ebuild
@@ -146,6 +146,7 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${FILESDIR}"/${PN}-4.18.4-pam.patch
"${FILESDIR}"/ldb-2.5.2-skip-wav-tevent-check.patch
+ "${FILESDIR}"/cmocka-config_h.patch
)
CONFDIR="${FILESDIR}/4.4"
diff --git a/net-fs/samba/samba-4.18.9.ebuild b/net-fs/samba/samba-4.18.9.ebuild
index 66c20828dd28..50ed3dd522ab 100644
--- a/net-fs/samba/samba-4.18.9.ebuild
+++ b/net-fs/samba/samba-4.18.9.ebuild
@@ -146,6 +146,7 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${FILESDIR}"/${PN}-4.18.4-pam.patch
"${FILESDIR}"/ldb-2.5.2-skip-wav-tevent-check.patch
+ "${FILESDIR}"/cmocka-config_h.patch
)
CONFDIR="${FILESDIR}/4.4"
diff --git a/net-fs/samba/samba-4.19.4.ebuild b/net-fs/samba/samba-4.19.4.ebuild
index 14523d446af3..9903c474ab38 100644
--- a/net-fs/samba/samba-4.19.4.ebuild
+++ b/net-fs/samba/samba-4.19.4.ebuild
@@ -146,6 +146,7 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${FILESDIR}"/${PN}-4.18.4-pam.patch
"${FILESDIR}"/ldb-2.5.2-skip-wav-tevent-check.patch
+ "${FILESDIR}"/cmocka-config_h.patch
)
CONFDIR="${FILESDIR}/4.4"