summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-03 05:36:23 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-03 05:45:20 +0200
commit93b7084a6d729f1e0c44814a8300f33209e682d6 (patch)
tree37aa904e48ded2d40e351e2891b3b509f1a0f4fe
parentdev-libs/jsoncpp: Bump to 1.9.0 (diff)
downloadgentoo-93b7084a.tar.gz
gentoo-93b7084a.tar.bz2
gentoo-93b7084a.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 1784b4ef0dca..43be74c09f5b 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-cpugraph-plugin-1.0.5.tar.bz2 328972 BLAKE2B 7c39aa6fd9d0d6ecc5bedce1d99d330765c329d1fa673b61282fdea654ebd997caa118f57dd0776008584eaa2dbe0a6ae7df532ed3b941b03b111f5ae753d2e8 SHA512 3d1246958dd30638104f14a8b0078e25c05b67b42da953a97cb51d2b04e70d3f1da9d42ca4f4575b7114bce5abc4cb94d598737631536c0575b55d9a391e210a
DIST xfce4-cpugraph-plugin-1.0.90.tar.bz2 386127 BLAKE2B ec1809f64fa2fc142aa6efec315e2c138b7b49261ecce4735cc0dce225c24c69013f4b2a4250dcdf1513029765d81cb757e0bb38ebb3bd024b5b07fe2e0475d0 SHA512 7f2be5b41948ba4c730e6fd58038e96044ef8d007ae55f107a434308bfffc99071706c92854e41a589a807913fb98b9b216c141fc1d37c744275d5a3944aee09
DIST xfce4-cpugraph-plugin-1.0.91.tar.bz2 377694 BLAKE2B da75c1295dc190923e1a16c2627fcb36517b00ded3a358c198152705ac220720b97db36a9e6b43c1efee11cbd95249acec38a0aa8985ce6b7d1e3c35a6d93d26 SHA512 513fdec6ed9c00b1f979c3ca9223667d7b50ccb55e9be9506497eade4d4495547e60e53507bf114aabd23af911a477f997c6f7c2944c1761125a12227c67ccf5
+DIST xfce4-cpugraph-plugin-1.1.0.tar.bz2 391629 BLAKE2B e1a18df75461466abf908100e3ace73c46751d78527a9928a5712e3b3388cb0908b697055bd229f700f3e36e908cbc90f2732fc65568ebbe47d876aa376fd087 SHA512 c928baac776517da8929b8ce3842be7e02a2b3394b7cc848028d1720ca611e1aa4ef706bd00736fecfed0b3b2d0cce94c09b0f905a226db5e50c036dabb8df2a
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.1.0.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.1.0.ebuild
new file mode 100644
index 000000000000..684e97eec64f
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}