summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-24 08:21:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-24 08:41:08 +0100
commit93d2335eee85a861a48dc289eccf4b922c66f74f (patch)
tree2bc2954881df344bb3f6a042b44364c1914d07f6
parentdev-python/alembic: Bump to 1.9.1 (diff)
downloadgentoo-93d2335e.tar.gz
gentoo-93d2335e.tar.bz2
gentoo-93d2335e.zip
dev-python/weasyprint: Bump to 57.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-57.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 5fbaad7ad069..53e981d36eb2 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST weasyprint-57.1.tar.gz 429652 BLAKE2B c94cc05f6c3b831d3214d7476e3fa799ff62d8fb575044a6f11172e650a87b1277e21fef40577bb01a1a778982a98e1a57801de708b3a3a26520b50aae8b43ac SHA512 0a130fba07d1d73eb4e9dcda27ab51ede45c440717f6fedb8d6aac09283244c366d36d85c2dac85995fbaebac21cf880a0cb684baaff3788af3eb6b4931c014b
+DIST weasyprint-57.2.tar.gz 429120 BLAKE2B c97ba3fb3eec431a7de9a1a8a440290005de11b11d4abac4dd993a7d2fc4c14e64bdf13b8f8c12d4ba4f94b2049e0b05c3fb950c8b204f446323038c9c471451 SHA512 11b9469d37820439b1d0dad0117dd1c9649011c71aabb0e27008b303e5c851215ce9f0b271da9a74d614e54cb23f9c6036b6e094016b5688f6b700fb7444338f
diff --git a/dev-python/weasyprint/weasyprint-57.2.ebuild b/dev-python/weasyprint/weasyprint-57.2.ebuild
new file mode 100644
index 000000000000..d6b0c790c834
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-57.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ || (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ <app-text/ghostscript-gpl-9.56.0
+ )
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest