summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-17 02:05:59 -0400
committerSam James <sam@gentoo.org>2024-05-19 17:01:43 +0100
commit93f46f4f8dfd02fc6bc515d6f8293a65dccfa154 (patch)
tree4f29e9e1d5e3abbc2645c55d70a1f90e49084bc4
parentdev-python/tree-sitter: add 0.22.3 (diff)
downloadgentoo-93f46f4f8dfd02fc6bc515d6f8293a65dccfa154.tar.gz
gentoo-93f46f4f8dfd02fc6bc515d6f8293a65dccfa154.tar.bz2
gentoo-93f46f4f8dfd02fc6bc515d6f8293a65dccfa154.zip
sys-apps/sed: regenerate autoconf to get a Modern C fix in
There are also some suppressions that are going to be added to portage itself for gnulib checks that are *expected* to fail. Backported to sys-apps/portage. [sam: Revbump.] Closes: https://bugs.gentoo.org/900382 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/sed/sed-4.9-r1.ebuild (renamed from sys-apps/sed/sed-4.9.ebuild)10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-apps/sed/sed-4.9.ebuild b/sys-apps/sed/sed-4.9-r1.ebuild
index ef4336465acc..96c05b2fc320 100644
--- a/sys-apps/sed/sed-4.9.ebuild
+++ b/sys-apps/sed/sed-4.9-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/sed.asc
-inherit flag-o-matic verify-sig
+inherit autotools flag-o-matic verify-sig
DESCRIPTION="Super-useful stream editor"
HOMEPAGE="https://www.gnu.org/software/sed/"
@@ -33,6 +33,12 @@ DEPEND="${RDEPEND}
BDEPEND="nls? ( sys-devel/gettext )
verify-sig? ( sec-keys/openpgp-keys-sed )"
+src_prepare() {
+ default
+ # Modern C fixes from latest autotools. bug #900382
+ eautoreconf
+}
+
src_configure() {
use static && append-ldflags -static