summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-16 23:31:17 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-16 23:32:52 -0700
commit93f678aa710bf50783a7e6b3428f3cd2679ff9b6 (patch)
tree7d625bb1c91428352f853014b2aa32ae41b45f3a
parentdev-libs/vala-common: Version bump to 0.52.5 (diff)
downloadgentoo-93f678aa710bf50783a7e6b3428f3cd2679ff9b6.tar.gz
gentoo-93f678aa710bf50783a7e6b3428f3cd2679ff9b6.tar.bz2
gentoo-93f678aa710bf50783a7e6b3428f3cd2679ff9b6.zip
dev-lang/vala: Version bump to 0.52.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-lang/vala/Manifest1
-rw-r--r--dev-lang/vala/vala-0.52.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-lang/vala/Manifest b/dev-lang/vala/Manifest
index c5364a7981ec..5918f91abb55 100644
--- a/dev-lang/vala/Manifest
+++ b/dev-lang/vala/Manifest
@@ -5,3 +5,4 @@ DIST vala-0.48.18.tar.xz 3519484 BLAKE2B 26581cd4b2ead9272fc032d085a4c49d47bc65d
DIST vala-0.50.7.tar.xz 3540048 BLAKE2B 4f3abdfe7f0448846f22a4d822b803484afd1a2371604d63cd7092e2854dbfdb15169ac74226404ca572bc8ac29d5262c6e39346271704003138b9881bd99b30 SHA512 50c4c257e0be020f45270b07fef3646712dc1556dd43ae9d54f164b97056b26779b3559deab9fe96afa11e2e97a13aa2cce348a34cf5d72ea6a3be4a8d7efc94
DIST vala-0.50.9.tar.xz 3543420 BLAKE2B 57b8021746aa554fe78f7e033b7c134a0d840e46ad7666f9abc3f019326282958cf90ddbebffe36fa15f80dff407a46b3a2e1298bfdfee749838d3a730bad5a5 SHA512 f138629fa0840941942796b33fe8cf61391f14e186f2bd70519cafc19bcc453fd16bcfaf7a44713a00531fe181bb9b0c4aafb955fae0a29fd9eaa12b48ed169a
DIST vala-0.52.4.tar.xz 3577796 BLAKE2B 20f541f5429ef52cdcb4b0c5559dc312f62276ac6d91b3ca97f5bce4b954f7d0407637131e16db5a9f059f5ee3e7d44a414cc06311d49c294f22789db821ec79 SHA512 3c7daae4d26e6940b0735cee84f1a25f2aab12c93d2a8a9e9edec45c0c9dc9184cc790acbae19aba0fb31dfd7115afddcf8b9f09b0423b5b6950900641f4c527
+DIST vala-0.52.5.tar.xz 3583412 BLAKE2B ee81903be59267ce3499dfd7ef4e73708431641a16ca3c806a64d1660b85e8977f125cd67de0f2cfec610d37395c5a56028eb1c888a024bd9a1b159e2111e75b SHA512 88522ab5d12a8fbf538ed6ca56a1f402f3749bdfcfc9cdee2ad7ebcf98ebcd606e976fded83f2d853ac32cbaf326d96d1d888a5c56d018389753ac43456fa82f
diff --git a/dev-lang/vala/vala-0.52.5.ebuild b/dev-lang/vala/vala-0.52.5.ebuild
new file mode 100644
index 000000000000..fa44e86dd988
--- /dev/null
+++ b/dev-lang/vala/vala-0.52.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vala"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.52"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="test valadoc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.48.0:2
+ >=dev-libs/vala-common-${PV}
+ valadoc? ( >=media-gfx/graphviz-2.16 )
+ !<net-libs/libsoup-2.66.2[vala]
+" # Older libsoup generates a libsoup-2.4.vapi that isn't fine for vala:0.46 anymore
+# We block here, so libsoup[vala] consumers wouldn't have to >= it, which would be bad
+# as the newer is not required with older vala when those are picked instead of 0.46.
+# vala-0.45.91 ships a broken libsoup-2.4.vapi copy too, but that'll be fixed by 0.45.92
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2
+ dev-libs/gobject-introspection
+ )
+"
+BDEPEND="
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+
+src_configure() {
+ # weasyprint enables generation of PDF from HTML
+ gnome2_src_configure \
+ --disable-unversioned \
+ $(use_enable valadoc) \
+ VALAC=: \
+ WEASYPRINT=:
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}