summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-24 20:45:36 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 20:40:31 +0100
commit9447cdf33681e7004f6754fef652107aa3241a5a (patch)
tree4bd5026b3b8a6a8a5043d25c2121727cb971baa9
parentdev-lua/luaposix: drop old version (diff)
downloadgentoo-9447cdf33681e7004f6754fef652107aa3241a5a.tar.gz
gentoo-9447cdf33681e7004f6754fef652107aa3241a5a.tar.bz2
gentoo-9447cdf33681e7004f6754fef652107aa3241a5a.zip
dev-lua/luacheck: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luacheck/Manifest1
-rw-r--r--dev-lua/luacheck/luacheck-0.20.0-r1.ebuild49
-rw-r--r--dev-lua/luacheck/luacheck-0.23.0-r1.ebuild56
3 files changed, 0 insertions, 106 deletions
diff --git a/dev-lua/luacheck/Manifest b/dev-lua/luacheck/Manifest
index f22c82aeba84..926e7bc8573a 100644
--- a/dev-lua/luacheck/Manifest
+++ b/dev-lua/luacheck/Manifest
@@ -1,2 +1 @@
-DIST luacheck-0.20.0.tar.gz 132693 BLAKE2B d485ef841c00241023a9cb9bd0e1f994da3b5e79dad01281e0203e1561f788f8d1e8db97910d3a82ab3daafb3dceef1fe2897beee9f16e71350fdff27eba7fe0 SHA512 08b1a64849b329e6ad71b1d7011fac0833de068641270adaa009e9a17139968ab73add3786a508a8787ce1fcfe1f028a35b5434221e4f1f62bea56833e0e65dd
DIST luacheck-0.23.0.tar.gz 158201 BLAKE2B c0780143a335b1deb7725819dbdac03446742fd459eed5a6de0cf3de5576f3be5379ff7086348b8880eba70dd5f7a1e719e9a09fdcc70abc293e1636f575ad57 SHA512 d76e4b22f1e9d868a8531ad51fb98607e5bfb1fbbd55053105d9978ba6c0455de99202c53d4e199733ea997863b26527fb84e7e9717209fd588f1d02db9db028
diff --git a/dev-lua/luacheck/luacheck-0.20.0-r1.ebuild b/dev-lua/luacheck/luacheck-0.20.0-r1.ebuild
deleted file mode 100644
index 857d9ef215df..000000000000
--- a/dev-lua/luacheck/luacheck-0.20.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-DESCRIPTION="A tool for linting and static analysis of Lua code"
-HOMEPAGE="https://github.com/mpeterv/luacheck"
-SRC_URI="https://github.com/mpeterv/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="doc luajit test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/luafilesystem[luajit(-)=]
- !luajit? ( >=dev-lang/lua-5.1:0= )
- luajit? ( dev-lang/luajit:2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? ( dev-lua/busted )"
-
-DOCS=( CHANGELOG.md README.md )
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- fi
-}
-
-src_test() {
- busted -o gtest || die
-}
-
-src_install() {
- local instdir
- instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
- insinto "${instdir#${EPREFIX}}"
- doins -r src/luacheck
-
- newbin bin/luacheck.lua luacheck
-
- use doc && HTML_DOCS+=( html/. )
-
- einstalldocs
-}
diff --git a/dev-lua/luacheck/luacheck-0.23.0-r1.ebuild b/dev-lua/luacheck/luacheck-0.23.0-r1.ebuild
deleted file mode 100644
index a22daf625f58..000000000000
--- a/dev-lua/luacheck/luacheck-0.23.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs
-
-DESCRIPTION="A tool for linting and static analysis of Lua code"
-HOMEPAGE="https://github.com/mpeterv/luacheck"
-SRC_URI="https://github.com/mpeterv/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86"
-IUSE="doc luajit test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/lua-argparse[luajit(-)=]
- dev-lua/luafilesystem[luajit(-)=]
- dev-lua/lua-utf8[luajit(-)=]
- !luajit? ( >=dev-lang/lua-5.1:0= )
- luajit? ( dev-lang/luajit:2 )"
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- test? (
- ${RDEPEND}
- dev-lua/busted
- )"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )
-
-src_compile() {
- if use doc; then
- sphinx-build docsrc html || die
- fi
-}
-
-src_test() {
- busted -o gtest || die
-}
-
-src_install() {
- local instdir
- instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"
- insinto "${instdir#${EPREFIX}}"
- doins -r src/luacheck
-
- newbin bin/luacheck.lua luacheck
-
- use doc && local HTML_DOCS=( html/. )
-
- local -a DOCS=( CHANGELOG.md LICENSE README.md )
- einstalldocs
-}