summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:18 +0200
commit9452bfebd055b2975e3dacd03c826eff66fce5c2 (patch)
tree7a016302f6f13299cbc646801e8d303e17fbf0fc
parentdev-python/doit-py: Remove redundant versions (diff)
downloadgentoo-9452bfebd055b2975e3dacd03c826eff66fce5c2.tar.gz
gentoo-9452bfebd055b2975e3dacd03c826eff66fce5c2.tar.bz2
gentoo-9452bfebd055b2975e3dacd03c826eff66fce5c2.zip
dev-python/dulwich: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.19.6.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 10c714c050ab..401b4853b78c 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,2 @@
DIST dulwich-0.19.15.tar.gz 369491 BLAKE2B ffaabbd68ee228e771b8a56c9a5b70498e49a4547f3f0ff87225ca4ee0a222fca5cd75a36293fb0d111615f4fe9550acd2825732a178f67d9f6b538abf9fc37f SHA512 ae56cf4748ea5f9d275f2d1456bf9fce77859ad2eeba6b7d8f34283e212404ba385f377f4fb86b88dc40982649ec8cfb12ea407dd25ada7cb2b0e862568ac7da
-DIST dulwich-0.19.6.tar.gz 349939 BLAKE2B a88836c8a6fa3f732643f88cb94ec37c138146336709651f7fbc604fe80ff3dcf88b24ffca5e5d14c3c947b847a9678fa8b431ef6be0b78e6046bcd3f7ed29bc SHA512 7e13b465672c5eee4f6d14f28e9cba63ceddf1ad119822fabd17b01ad6b89c6dd8c0bbf562bdf50e0ada5ce17bcad531549054417d744e5cf64a610e8a1740bc
DIST dulwich-0.20.5.tar.gz 384166 BLAKE2B f11ef1467a7f850666a850c42871b2bb798cdad54b4ad5a7d6fef8171cb5378982537574f9d2c783e2c9e7357624eec4c617c0b014d789d9f40f5bdfd56d8b39 SHA512 88c546fdc6cb4fbde1ebab5160e1f226259d85c934bee456c8a93b14f4c292550e685696fd25c27635f3342f82b0c67572059fb90e3e9b339aa0d11b9e010c25
diff --git a/dev-python/dulwich/dulwich-0.19.6.ebuild b/dev-python/dulwich/dulwich-0.19.6.ebuild
deleted file mode 100644
index 27d31728a85c..000000000000
--- a/dev-python/dulwich/dulwich-0.19.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.org/project/dulwich/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.21[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/geventhttpclient[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/python-fastimport[${PYTHON_USEDEP}]
- )"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-# One test sometimes fails
-# https://github.com/jelmer/dulwich/issues/541
-PATCHES=( "${FILESDIR}/${PN}-0.18.3-skip-failing-test.patch" )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Do not use make check which rebuilds the extension and uses -Werror,
- # causing unexpected failures.
- "${EPYTHON}" -m unittest dulwich.tests.test_suite \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}