summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-22 10:37:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-22 10:52:56 +0200
commit945b213eb8d07eaf5d1a4d359ab2b13378354f9d (patch)
treea2c5eac256e1c1ba90c367c2145acb07e2c24518
parentapp-emulation/free42: Drop old (diff)
downloadgentoo-945b213e.tar.gz
gentoo-945b213e.tar.bz2
gentoo-945b213e.zip
media-libs/xine-lib: Fixed compilation with >=x11-libs/libxcb-1.12
Gentoo bug #584640 Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch25
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.6-r1.ebuild17
2 files changed, 33 insertions, 9 deletions
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch b/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch
new file mode 100644
index 000000000000..cc17643d9c56
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch
@@ -0,0 +1,25 @@
+https://bugs.xine-project.org/show_bug.cgi?id=572
+https://bugs.gentoo.org/584640
+
+--- xine-lib-1.2.6/m4/video_out.m4
++++ xine-lib-1.2.6/m4/video_out.m4
+@@ -305,7 +305,7 @@
+ dnl xcb
+ XINE_ARG_WITH([xcb], [Enable support for XCB video out plugins])
+ if test x"$with_xcb" != x"no"; then
+- PKG_CHECK_MODULES([XCB], [xcb-shape >= 1.0], [have_xcb=yes], [have_xcb=no])
++ PKG_CHECK_MODULES([XCB], [xcb xcb-shape >= 1.0], [have_xcb=yes], [have_xcb=no])
+ if test x"$hard_enable_xcb" = x"yes" && test x"$have_xcb" != x"yes"; then
+ AC_MSG_ERROR([XCB support requested, but XCB not found])
+ elif test x"$have_xcb" = x"yes"; then
+--- xine-lib-1.2.6/src/video_out/Makefile.am
++++ xine-lib-1.2.6/src/video_out/Makefile.am
+@@ -147,7 +147,7 @@
+ xineplug_vo_out_xcbshm_la_CFLAGS = $(AM_CFLAGS) $(XCB_CFLAGS) $(XCBSHM_CFLAGS) $(AVUTIL_CFLAGS)
+
+ xineplug_vo_out_xcbxv_la_SOURCES = video_out_xcbxv.c $(XCBOSD)
+-xineplug_vo_out_xcbxv_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS) $(LTLIBINTL) $(XCBXV_LIBS) $(XCB_LIBS)
++xineplug_vo_out_xcbxv_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS) $(LTLIBINTL) $(XCBXV_LIBS) $(XCBSHM_LIBS) $(XCB_LIBS)
+ xineplug_vo_out_xcbxv_la_CFLAGS = $(AM_CFLAGS) $(XCB_CFLAGS) $(XCBXV_CFLAGS)
+
+ xineplug_vo_out_xshm_la_SOURCES = video_out_xshm.c $(X11OSD)
diff --git a/media-libs/xine-lib/xine-lib-1.2.6-r1.ebuild b/media-libs/xine-lib/xine-lib-1.2.6-r1.ebuild
index 032fd3c6438c..18a0be4cd8ce 100644
--- a/media-libs/xine-lib/xine-lib-1.2.6-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.2.6-r1.ebuild
@@ -4,11 +4,11 @@
EAPI=6
-inherit flag-o-matic libtool multilib eutils
+inherit autotools flag-o-matic libtool multilib eutils
if [[ ${PV} == *9999* ]]; then
EHG_REPO_URI="http://hg.debian.org/hg/xine-lib/xine-lib-1.2"
- inherit autotools mercurial eutils
+ inherit mercurial eutils
unset NLS_IUSE
NLS_DEPEND="sys-devel/gettext"
NLS_RDEPEND="virtual/libintl"
@@ -116,23 +116,22 @@ REQUIRED_USE="vidix? ( || ( X fbcon ) )
xv? ( X )
xinerama? ( X )"
+PATCHES=(
+ "${FILESDIR}/${P}-libxcb-1.12.patch"
+)
+
src_prepare() {
default
sed -i -e '/define VDR_ABS_FIFO_DIR/s|".*"|"/var/vdr/xine"|' src/vdr/input_vdr.c || die
+ has_version '>=media-video/ffmpeg-2.9' && eapply "${FILESDIR}/ffmpeg29.patch"
- if [[ ${PV} == *9999* ]]; then
- epatch_user
- eautoreconf
- else
- elibtoolize
- fi
+ eautoreconf
local x
for x in 0 1 2 3; do
sed -i -e "/^O${x}_CFLAGS=\"-O${x}\"/d" configure || die
done
- has_version '>=media-video/ffmpeg-2.9' && eapply "${FILESDIR}/ffmpeg29.patch"
}
src_configure() {