summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 14:41:13 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 14:54:04 +0100
commit94641762d9211adbd1b95b6dcd03bed4faa5d258 (patch)
tree3fcb44c9291816a000b329536e670d27851757a6
parentmedia-sound/spek: Port to wxGTK 3.2 (diff)
downloadgentoo-94641762.tar.gz
gentoo-94641762.tar.bz2
gentoo-94641762.zip
media-sound/spek: drop 0.8.3-r1, 0.8.4
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--media-sound/spek/Manifest2
-rw-r--r--media-sound/spek/files/spek-0.8.1-disable-updates.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-AR.patch18
-rw-r--r--media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch33
-rw-r--r--media-sound/spek/files/spek-0.8.3-ffmpeg3.patch37
-rw-r--r--media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-stdlib.patch22
-rw-r--r--media-sound/spek/spek-0.8.3-r1.ebuild44
-rw-r--r--media-sound/spek/spek-0.8.4.ebuild33
9 files changed, 0 insertions, 211 deletions
diff --git a/media-sound/spek/Manifest b/media-sound/spek/Manifest
index 9818c2bad9f4..ca9e2b639607 100644
--- a/media-sound/spek/Manifest
+++ b/media-sound/spek/Manifest
@@ -1,3 +1 @@
-DIST spek-0.8.3.tar.gz 1349573 BLAKE2B ce783c319741c43f27462caf9dcd27e71f4c8fbc9d3a3d2ac0b977189cca4cf8ed14f258958bbf59532c4cae97562fa20819222ae68567e9e607f243a2777000 SHA512 a4b54746316d295574bc963e650728b23b3730ee6bcc8d78b043a5678baac70a0e859870120de2b0e6a17059e9e3757075f4691e2abde98c083afc393e93e17c
-DIST spek-0.8.4.tar.xz 430096 BLAKE2B 4b3a512f0a8e74650161c9ed7ef0e054325d9f42743362180d970854fccc99cf20fcf329643ffbd0e84a5ee0aff746d2fc2750b91f300e29243ce1194b1b0d9d SHA512 08e39d4c0c7732feec159a8ff29550a62bab37a01325589787e027a027c50ee926f4cd9e0971061bf4e0b53a590b842c6586b4173e09cc9b27dd3b5668dc2d8b
DIST spek-0.8.5.tar.xz 430464 BLAKE2B 54c977cc38f8162ec7fe45fe9eca023a9bdd2c1b42c0ad80dcf07c15ab93b416f58b499a3e8a9b9bb2ed16143deb899ce1c4fed2eba6b0e78eeab8b23a3326e7 SHA512 25f72c9372b142183ab34c47f1d7d6e62b9316d94b31aacff5d3ca007be030f4848a385be1bbb98f285aba010804fd429a7e099e597c30861347f5b8ed50d5b1
diff --git a/media-sound/spek/files/spek-0.8.1-disable-updates.patch b/media-sound/spek/files/spek-0.8.1-disable-updates.patch
deleted file mode 100644
index e035a4c60819..000000000000
--- a/media-sound/spek/files/spek-0.8.1-disable-updates.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- spek-0.8.1/src/spek-preferences.cc
-+++ spek-0.8.1/src/spek-preferences.cc
-@@ -62,7 +62,7 @@
-
- bool SpekPreferences::get_check_update()
- {
-- bool result = true;
-+ bool result = false;
- this->config->Read(wxT("/update/check"), &result);
- return result;
- }
diff --git a/media-sound/spek/files/spek-0.8.3-AR.patch b/media-sound/spek/files/spek-0.8.3-AR.patch
deleted file mode 100644
index be797ba663fc..000000000000
--- a/media-sound/spek/files/spek-0.8.3-AR.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Bug: https://bugs.gentoo.org/754861
-https://github.com/alexkay/spek/pull/198
-
-diff --git a/configure.ac b/configure.ac
-index 3fc451b..b270033 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -5,6 +5,7 @@ AM_INIT_AUTOMAKE([1.11.1 foreign no-dist-gzip dist-xz serial-tests])
- AM_SILENT_RULES([yes])
-
- AC_LANG([C++])
-+AM_PROG_AR
- AC_PROG_CXX
- CXXFLAGS="$CXXFLAGS -std=gnu++11 -Wall -Wextra"
- AC_PROG_CXXCPP
---
-2.26.2
-
diff --git a/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch b/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch
deleted file mode 100644
index dee0e3ca0f8f..000000000000
--- a/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/alexkay/spek/commit/ee8bc49ed4a93a14a933ecb0eebfe424111f8413
-
-Index: spek-0.8.3/src/spek-audio.cc
-===================================================================
---- spek-0.8.3.orig/src/spek-audio.cc
-+++ spek-0.8.3/src/spek-audio.cc
-@@ -202,7 +202,7 @@ AudioFileImpl::AudioFileImpl(
- this->packet.data = nullptr;
- this->packet.size = 0;
- this->offset = 0;
-- this->frame = avcodec_alloc_frame();
-+ this->frame = av_frame_alloc();
- this->buffer_size = 0;
- this->buffer = nullptr;
- this->frames_per_interval = 0;
-@@ -218,7 +218,7 @@ AudioFileImpl::~AudioFileImpl()
- if (this->frame) {
- // TODO: Remove this check after Debian switches to libav 9.
- #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(54, 28, 0)
-- avcodec_free_frame(&this->frame);
-+ av_frame_free(&this->frame);
- #else
- av_freep(&this->frame);
- #endif
-@@ -258,7 +258,7 @@ int AudioFileImpl::read()
-
- for (;;) {
- while (this->packet.size > 0) {
-- avcodec_get_frame_defaults(this->frame);
-+ av_frame_unref(this->frame);
- auto codec_context = this->format_context->streams[this->audio_stream]->codec;
- int got_frame = 0;
- int len = avcodec_decode_audio4(codec_context, this->frame, &got_frame, &this->packet);
diff --git a/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch b/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch
deleted file mode 100644
index ad82a38c31c5..000000000000
--- a/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-commit 1ef950dcbf89dd8adf816009b54009f487828a45
-Author: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
-Date: Sun Mar 27 14:19:42 2016 -0700
-
- Replace deprecated FFmpeg API
-
-diff --git a/src/spek-audio.cc b/src/spek-audio.cc
-index b7633bc..21ea7a4 100644
---- a/src/spek-audio.cc
-+++ b/src/spek-audio.cc
-@@ -222,7 +222,7 @@ AudioFileImpl::~AudioFileImpl()
- this->packet.data -= this->offset;
- this->packet.size += this->offset;
- this->offset = 0;
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
- if (this->format_context) {
- if (this->audio_stream >= 0) {
-@@ -326,7 +326,7 @@ int AudioFileImpl::read()
- this->packet.data -= this->offset;
- this->packet.size += this->offset;
- this->offset = 0;
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
-
- int res = 0;
-@@ -334,7 +334,7 @@ int AudioFileImpl::read()
- if (this->packet.stream_index == this->audio_stream) {
- break;
- }
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
- if (res < 0) {
- // End of file or error.
diff --git a/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch b/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
deleted file mode 100644
index 624e969dba4a..000000000000
--- a/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- spek-0.8.3/configure.ac
-+++ spek-0.8.3/configure.ac
-@@ -6,7 +6,7 @@
-
- AC_LANG([C++])
- AC_PROG_CXX
--CXXFLAGS="$CXXFLAGS -std=gnu++11 -Wall -Wextra"
-+CXXFLAGS="$CXXFLAGS -std=c++11 -Wall -Wextra"
- AC_PROG_CXXCPP
- AC_PROG_RANLIB
- AC_PROG_INSTALL
diff --git a/media-sound/spek/files/spek-0.8.3-stdlib.patch b/media-sound/spek/files/spek-0.8.3-stdlib.patch
deleted file mode 100644
index c0ffa16b4d52..000000000000
--- a/media-sound/spek/files/spek-0.8.3-stdlib.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://bugs.gentoo.org/519450
-
---- spek-0.8.3/src/spek-fft.cc
-+++ spek-0.8.3/src/spek-fft.cc
-@@ -17,6 +17,7 @@
- */
-
- #include <math.h>
-+#include <stdlib.h>
-
- #define __STDC_CONSTANT_MACROS
- extern "C" {
---- spek-0.8.3/src/spek-events.cc
-+++ spek-0.8.3/src/spek-events.cc
-@@ -16,6 +16,7 @@
- * along with Spek. If not, see <http://www.gnu.org/licenses/>.
- */
-
-+#include <stdlib.h>
- #include "spek-events.h"
-
- //IMPLEMENT_DYNAMIC_CLASS(SpekHaveSampleEvent, wxEvent)
diff --git a/media-sound/spek/spek-0.8.3-r1.ebuild b/media-sound/spek/spek-0.8.3-r1.ebuild
deleted file mode 100644
index be7cff895114..000000000000
--- a/media-sound/spek/spek-0.8.3-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-WX_GTK_VER="3.0"
-
-inherit autotools wxwidgets xdg
-
-DESCRIPTION="Analyse your audio files by showing their spectrogram"
-HOMEPAGE="http://www.spek-project.org/"
-SRC_URI="https://github.com/alexkay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- media-video/ffmpeg:0=
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.1-disable-updates.patch
- "${FILESDIR}"/${P}-replace-gnu+11-with-c++11.patch
- "${FILESDIR}"/${P}-stdlib.patch
- "${FILESDIR}"/${P}-ffmpeg3.patch
- "${FILESDIR}"/${P}-ffmpeg3-1.patch
- "${FILESDIR}"/${P}-AR.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- setup-wxwidgets unicode
- default
-}
diff --git a/media-sound/spek/spek-0.8.4.ebuild b/media-sound/spek/spek-0.8.4.ebuild
deleted file mode 100644
index 437ebc2afb97..000000000000
--- a/media-sound/spek/spek-0.8.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WX_GTK_VER="3.0-gtk3"
-
-inherit wxwidgets xdg
-
-DESCRIPTION="Analyse your audio files by showing their spectrogram"
-HOMEPAGE="http://spek.cc/"
-SRC_URI="https://github.com/alexkay/spek/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- media-video/ffmpeg:=
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.4-disable-updates.patch
-)
-
-src_configure() {
- setup-wxwidgets unicode
- default
-}