summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-21 07:32:26 +0000
committerSam James <sam@gentoo.org>2023-07-23 02:49:50 +0100
commit9469342c7d179f27f09bf03fc6bd85d62b408fa9 (patch)
treede9ececab137be26a0c27cb8a48e803085a9d7fd
parentapp-arch/dump: fix incompatible pointer to integer conversion (diff)
downloadgentoo-9469342c7d179f27f09bf03fc6bd85d62b408fa9.tar.gz
gentoo-9469342c7d179f27f09bf03fc6bd85d62b408fa9.tar.bz2
gentoo-9469342c7d179f27f09bf03fc6bd85d62b408fa9.zip
sci-electronics/gsmc: Fix call to undeclared function recalc
Closes: https://bugs.gentoo.org/886137 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31991 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-electronics/gsmc/files/gsmc-1.1-clang16-build-fix.patch41
-rw-r--r--sci-electronics/gsmc/gsmc-1.1-r3.ebuild38
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-electronics/gsmc/files/gsmc-1.1-clang16-build-fix.patch b/sci-electronics/gsmc/files/gsmc-1.1-clang16-build-fix.patch
new file mode 100644
index 000000000000..bc813a0bed20
--- /dev/null
+++ b/sci-electronics/gsmc/files/gsmc-1.1-clang16-build-fix.patch
@@ -0,0 +1,41 @@
+Bug: https://bugs.gentoo.org/886137
+--- a/autotune.c
++++ b/autotune.c
+@@ -29,6 +29,8 @@
+ #include <math.h>
+ #include "main.h"
+ #include "autotune.h"
++#include "draw.h"
++#include "calc.h"
+ #include <unistd.h>
+
+
+--- a/main.h
++++ b/main.h
+@@ -112,4 +112,6 @@ gint mdw_expose_event(GtkWidget *, GdkEventExpose *, gpointer),
+
+ void writespice(char *);
+ void removene(void);
++void loadgw(char *);
++void savegw(char *);
+
+--- a/print.c
++++ b/print.c
+@@ -32,6 +32,7 @@
+ #include "main.h"
+ #include "calc.h"
+ #include "print.h"
++#include "draw.h"
+ // jvdh 2004-3-30
+
+ extern SMCDATA smcdata;
+--- a/widget.c
++++ b/widget.c
+@@ -36,6 +36,7 @@
+ #include "widget.h"
+ #include "draw.h"
+ #include "print.h"
++#include "autotune.h"
+
+ extern GtkTextBuffer *txtcircbuff;
+ extern int Zcirc, Ycirc, RHOcirc, Qcirc, tsidx, fsidx;
diff --git a/sci-electronics/gsmc/gsmc-1.1-r3.ebuild b/sci-electronics/gsmc/gsmc-1.1-r3.ebuild
new file mode 100644
index 000000000000..ebd74cd54aa1
--- /dev/null
+++ b/sci-electronics/gsmc/gsmc-1.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A GTK program for doing Smith Chart calculations"
+HOMEPAGE="https://www.qsl.net/ik5nax/"
+SRC_URI="https://www.qsl.net/ik5nax/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-clang16-build-fix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README TODO
+ insinto /usr/share/${PN}
+ doins example*
+}