summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-09-19 10:01:31 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-09-19 10:02:55 +0200
commit947ba1da0999c9c613d32c92cbeb59579aa466d6 (patch)
tree2edb0f357f3a3c8153bd43e0d3160bad3642f3bb
parentdev-ruby/actionmailbox: fix test dependencies (diff)
downloadgentoo-947ba1da.tar.gz
gentoo-947ba1da.tar.bz2
gentoo-947ba1da.zip
media-libs/libheif: Enable libde265 unconditionally
- Since libheif can't decode HEIF file without it it's not a good idea to disable libde265 support, so let's just enable it unconditionally Closes: https://bugs.gentoo.org/813669 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--media-libs/libheif/libheif-1.12.0-r1.ebuild (renamed from media-libs/libheif/libheif-1.12.0.ebuild)8
-rw-r--r--media-libs/libheif/libheif-9999.ebuild10
-rw-r--r--media-libs/libheif/metadata.xml1
3 files changed, 9 insertions, 10 deletions
diff --git a/media-libs/libheif/libheif-1.12.0.ebuild b/media-libs/libheif/libheif-1.12.0-r1.ebuild
index 6dc4980f1f24..f90f0e7b6ccb 100644
--- a/media-libs/libheif/libheif-1.12.0.ebuild
+++ b/media-libs/libheif/libheif-1.12.0-r1.ebuild
@@ -18,20 +18,20 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.12"
-IUSE="+aom gdk-pixbuf go libde265 rav1e test +threads x265"
-REQUIRED_USE="test? ( go libde265 )"
+IUSE="+aom gdk-pixbuf go rav1e test +threads x265"
+REQUIRED_USE="test? ( go )"
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
DEPEND="
media-libs/dav1d:=[${MULTILIB_USEDEP}]
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
media-libs/libpng:0=[${MULTILIB_USEDEP}]
sys-libs/zlib:=[${MULTILIB_USEDEP}]
virtual/jpeg:0=[${MULTILIB_USEDEP}]
aom? ( >=media-libs/libaom-2.0.0:=[${MULTILIB_USEDEP}] )
gdk-pixbuf? ( x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}] )
go? ( dev-lang/go )
- libde265? ( media-libs/libde265:=[${MULTILIB_USEDEP}] )
rav1e? ( media-video/rav1e:= )
x265? ( media-libs/x265:=[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"
@@ -50,10 +50,10 @@ src_prepare() {
multilib_src_configure() {
export GO111MODULE=auto
local econf_args=(
+ --enable-libde265
--disable-static
$(multilib_is_native_abi && use go || echo --disable-go)
$(use_enable aom)
- $(use_enable libde265)
$(use_enable gdk-pixbuf)
$(use_enable rav1e)
$(use_enable threads multithreading)
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
index 05d7c5f68ed0..a1837ad0964d 100644
--- a/media-libs/libheif/libheif-9999.ebuild
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/strukturag/libheif/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi
DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
@@ -18,20 +18,20 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.12"
-IUSE="+aom gdk-pixbuf go libde265 rav1e test +threads x265"
-REQUIRED_USE="test? ( go libde265 )"
+IUSE="+aom gdk-pixbuf go rav1e test +threads x265"
+REQUIRED_USE="test? ( go )"
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
DEPEND="
media-libs/dav1d:=[${MULTILIB_USEDEP}]
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
media-libs/libpng:0=[${MULTILIB_USEDEP}]
sys-libs/zlib:=[${MULTILIB_USEDEP}]
virtual/jpeg:0=[${MULTILIB_USEDEP}]
aom? ( >=media-libs/libaom-2.0.0:=[${MULTILIB_USEDEP}] )
gdk-pixbuf? ( x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}] )
go? ( dev-lang/go )
- libde265? ( media-libs/libde265:=[${MULTILIB_USEDEP}] )
rav1e? ( media-video/rav1e:= )
x265? ( media-libs/x265:=[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"
@@ -50,10 +50,10 @@ src_prepare() {
multilib_src_configure() {
export GO111MODULE=auto
local econf_args=(
+ --enable-libde265
--disable-static
$(multilib_is_native_abi && use go || echo --disable-go)
$(use_enable aom)
- $(use_enable libde265)
$(use_enable gdk-pixbuf)
$(use_enable rav1e)
$(use_enable threads multithreading)
diff --git a/media-libs/libheif/metadata.xml b/media-libs/libheif/metadata.xml
index c8f0f34e8094..2d2f28772dda 100644
--- a/media-libs/libheif/metadata.xml
+++ b/media-libs/libheif/metadata.xml
@@ -9,7 +9,6 @@
<flag name="aom">Use <pkg>media-libs/libaom</pkg> for AVIF encoding/decoding</flag>
<flag name="gdk-pixbuf">Enable <pkg>x11-libs/gdk-pixbuf</pkg> plugin</flag>
<flag name="go">Enable building <pkg>dev-lang/go</pkg> code/examples</flag>
- <flag name="libde265">Use <pkg>media-libs/libde265</pkg> for HEIF decoding</flag>
<flag name="rav1e">Use <pkg>media-video/rav1e</pkg> for AVIF encoding</flag>
<flag name="x265">Use <pkg> media-libs/x265</pkg> for HEIF encoding</flag>
</use>