summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-22 22:29:15 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-22 22:35:31 +0100
commit947e547029b66035858de76f3152bc17f64b6ab9 (patch)
treee05b9e8b0ab7da8672188ea31fe5c3b99d48a48f
parentsys-auth/rtkit: drop 0.13-r1 (diff)
downloadgentoo-947e547029b66035858de76f3152bc17f64b6ab9.tar.gz
gentoo-947e547029b66035858de76f3152bc17f64b6ab9.tar.bz2
gentoo-947e547029b66035858de76f3152bc17f64b6ab9.zip
app-misc/gramps: drop 5.1.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-misc/gramps/Manifest1
-rw-r--r--app-misc/gramps/gramps-5.1.5.ebuild105
-rw-r--r--app-misc/gramps/metadata.xml1
3 files changed, 0 insertions, 107 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index d21cf246dbc7..e03b8f571b65 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1,2 +1 @@
-DIST gramps-5.1.5.tar.gz 17425167 BLAKE2B f07fcb84c28f1def84c5568da6ac38a78def8657a0ee010163cb7e0899dd94ebb1c851e2c9d207fd9725754363ac7243a66f0de6e0d9708270d2d43c90485212 SHA512 8e36e8da7cfb41cc0c77881993cfc212a15bf9775dad3c8be131889b70360117e023b6837b91dad28fc03198080290a08c8089856c753246ff14c7fc3bca38be
DIST gramps-5.1.6.tar.gz 17429153 BLAKE2B fe94d80ff209e1f27ec1cfa533e916514336c1d367435e0a9da4b8309efbc9c047302a67ec24e28237eaead67ff63e76bd1384ac1e3df10e08ae98aca126566b SHA512 419bbfa54ca3bf33e71fd579c84a56eebe4afc78ccd50c23b2d62869684709ccbf373e8da0e65835d9fc21a29d2d144597d6cf8c425e14c91574535d4b1ab64d
diff --git a/app-misc/gramps/gramps-5.1.5.ebuild b/app-misc/gramps/gramps-5.1.5.ebuild
deleted file mode 100644
index 89f5b7547f9c..000000000000
--- a/app-misc/gramps/gramps-5.1.5.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="sqlite"
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Community genealogy program aiming to be both intuitive and feature-complete"
-HOMEPAGE="https://gramps-project.org/"
-SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="berkdb exif geo postscript +rcs +reports spell test"
-
-# Previously had: !berkdb? ( test ) combined w/ dev-python/bsddb3 dep only for py3.9
-# so now restricted entirely.
-# See also https://github.com/gramps-project/gramps/pull/1408.
-RESTRICT="test"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
- dev-python/pyicu[${PYTHON_USEDEP}]
- exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
- ')
- gnome-base/librsvg:2
- >x11-libs/gtk+-3.14.8:3[introspection]
- x11-libs/pango[introspection]
- x11-misc/xdg-utils
- geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
- spell? ( app-text/gtkspell:3[introspection] )
- rcs? ( dev-vcs/rcs )
- reports? ( media-gfx/graphviz[postscript?] )
-"
-BDEPEND="test? ( ${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- ')
-)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.1.3-test_locale.patch
-)
-
-python_prepare_all() {
- # Install documentation to the proper location. This can't be done
- # easily with a patch because we substitute in the ${PF} variable,
- # and that changes with every revision.
- sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- DISTUTILS_ARGS=(
- --resourcepath=/usr/share
- --no-compress-manpages
- )
-}
-
-python_test() {
- # Gramps builds just fine out of tree but it confuses its test suite.
- # The following might be an ugly hack but at least it lets the tests
- # run properly until either I or upstream have come up with something
- # better. FIXME: test this when a new release comes out.
- rm -rf "${S}/build" && ln -s "${BUILD_DIR}" "${S}"/build || \
- die "Failed to symlink build directory to source directory"
-
- # Set a sane default locale for the tests which do not explicitly set one.
- local -x LC_ALL=C.UTF-8
-
- esetup.py test || die
-}
-
-# Ugly hack to work around Bug #717922
-python_install() {
- local DISTUTILS_ARGS=(
- --resourcepath=/usr/share
- --no-compress-manpages
- build
- )
- distutils-r1_python_install
- echo -n "${EPREFIX}/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
diff --git a/app-misc/gramps/metadata.xml b/app-misc/gramps/metadata.xml
index 06500c9ec887..8e10fde3694a 100644
--- a/app-misc/gramps/metadata.xml
+++ b/app-misc/gramps/metadata.xml
@@ -88,7 +88,6 @@
zapolnjevanju vrzeli v rodoslovnih podatkih.
</longdescription>
<use>
- <flag name="berkdb">Support BerkeleyDB-based family trees produced by older versions of Gramps</flag>
<flag name="geo">Enable rendering of geographical data using <pkg>sci-geosciences/osm-gps-map</pkg></flag>
<flag name="reports">All external software that is needed for graphical reports will be installed</flag>
<flag name="rcs">Adds support for family tree archives via <pkg>dev-vcs/rcs</pkg></flag>