summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2020-12-29 12:51:21 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-12-29 12:51:21 +0000
commit947f3d307a7ccf44dbff3aab652dd123c71a4013 (patch)
tree62659ec73f0d89d58bb0b96dc878f06db0c79f11
parentdev-python/pytest-xprocess: Remove old (diff)
downloadgentoo-947f3d30.tar.gz
gentoo-947f3d30.tar.bz2
gentoo-947f3d30.zip
dev-libs/libstrophe: add new version 0.10.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--dev-libs/libstrophe/Manifest1
-rw-r--r--dev-libs/libstrophe/libstrophe-0.10.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/Manifest b/dev-libs/libstrophe/Manifest
index 9097c741aa9c..6a0cc0156fe5 100644
--- a/dev-libs/libstrophe/Manifest
+++ b/dev-libs/libstrophe/Manifest
@@ -1,3 +1,4 @@
DIST libstrophe-0.10.0.tar.gz 520645 BLAKE2B 85998ffa7d2051bf3372842a0bc6d5404932c41853609943ae0420760e0434a74b711bd5f23657f061f1227647247b1989833c54c11a88490fe7617459687818 SHA512 9d2e8f95ab5f9611529e18b0130322a196d4b59aae69c931a6d7dc462d4a6a4fa395d6fbca56d9f329fc943e3de005b570ea34629a504175f3f2ec91f85bf40a
+DIST libstrophe-0.10.1.tar.gz 520649 BLAKE2B aa5cf0c972d7ae8731752f351dc3c1d6d230b8a1411417a81126543dd47e79e324a8c258cbc4c2e608c748d62211dcde3802cb92bb3612c6a33bcd2209182a90 SHA512 1ee3cb76cdc76711b4928d69fb8add974ab8359b729ec12003d73530c93492f4e8d208cacbd50f8db7509bc01f56a9f945348bc3a6fdd18a7080b751fff8a783
DIST libstrophe-0.9.2.tar.gz 500459 BLAKE2B 0b1f6f1daac1215bcdcbde0e54264b98f5a863de339500826f625f8c5e8143ce7200fb251d04248715e9a8b6621a4360e7ca2780bf4684d916ec13361b5f6fcc SHA512 a0129c49ca574afaefa77c412143571af2eb1100c7d737d497b65d44680d35e2404ee2d4d4e1378b06ac1bcc5c587f505f79fea9251af1cbb36afd990d48570d
DIST libstrophe-0.9.3.tar.gz 502449 BLAKE2B 662b0c329b0bf7d7f34fc80bf0608b921fa1ad54c8277e88f23f3ed17d0892dc7e3d9bcaaa9707306801e9254bba4a127390025ab95e1d9d850c299a7b26d980 SHA512 9c8ba980f532c5576c2c5a9e3cdca9f833ec78debcb06b17e2f534de0e710ec416b997b0498be77a89fa7f57187456edb1d602993c695a5e738718ea593697a5
diff --git a/dev-libs/libstrophe/libstrophe-0.10.1.ebuild b/dev-libs/libstrophe/libstrophe-0.10.1.ebuild
new file mode 100644
index 000000000000..5757ff621942
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.10.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="|| ( MIT GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc expat libressl"
+
+RDEPEND="
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2:2 )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ # shellcheck disable=SC2207
+ local myeconf=(
+ --enable-tls
+ $(use_with !expat libxml2)
+ )
+ econf "${myeconf[@]}"
+}
+src_compile() {
+ default
+ if use doc; then
+ doxygen || die
+ HTML_DOCS=( docs/html/* )
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r examples
+ find "${D}" -name '*.la' -o -name '*.a' -delete || die
+}
+
+# Explicit src_test is there to document that the test suite is integrated and
+# is expected to pass. Please do not remove.
+src_test() {
+ emake check
+}