summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-04-21 18:36:29 -0300
committerMart Raudsepp <leio@gentoo.org>2024-04-28 23:43:25 +0300
commit9486a70ea5b772bbc9ed56bf84038cb9c337723a (patch)
tree0000e899250468cf6ce69fe6401f17f9b8800225
parentmail-client/evolution: ebuild touchups (diff)
downloadgentoo-9486a70ea5b772bbc9ed56bf84038cb9c337723a.tar.gz
gentoo-9486a70ea5b772bbc9ed56bf84038cb9c337723a.tar.bz2
gentoo-9486a70ea5b772bbc9ed56bf84038cb9c337723a.zip
gnome-extra/evolution-ews: Bump to 3.52.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-extra/evolution-ews/Manifest1
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.52.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index e777d5e023a9..89ede7b991c4 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,2 +1,3 @@
DIST evolution-ews-3.50.2.tar.xz 707800 BLAKE2B 18241eff067658af2f4620af87dea1c9c7c62476bbf9bf259addf15868a3b7e3f156dc952f21af2cad7ba6c2da9fd348b8733e5887f4276ad7eeeca8f9088476 SHA512 9aa4bb023922e39132a0ac3171d95f8362116960aa14dcb961b31ad242e6d7bcf2e946f19aea2c6f9a5324ca0954731264594a27fbb2b0e2cc38eca0cf441108
DIST evolution-ews-3.50.3.tar.xz 708336 BLAKE2B e8fe4e2a6539142847d6610a61e2f57a83d604946270cd7b23d7e34fa89a38f644a05e452bbc03a6d96553936a38719afb7296eed03c7134735f937943d57114 SHA512 12c7fbe72f375837f185d4c8dbcb2167d327a0ad4b2ca822e4e5349d561e996e7a7405c6f8d36ceeddff0015286117db66a65d2756003aa8ca96948d7826e51f
+DIST evolution-ews-3.52.1.tar.xz 716152 BLAKE2B 91a4ff7ed1b9cb718a42a20bc08b4e12f10caf18534cd72e9f5cbe90161fbeb0af40bf52075a1a83e96f44ed6aac2cc4ad917e1ce49dcc0e26cd56f129b60951 SHA512 24f964019b08261e9b330a1b6663d835e07235e817aea4399c3dab1f35bf4bfb7543f82c91f23f6df6e56e0dff45d1f9ab23362d3603f9a64f6e1c63de75c450
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.52.1.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.52.1.ebuild
new file mode 100644
index 000000000000..5d91684b2f80
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.52.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/evolution/-/wikis/home https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( >=net-libs/uhttpmock-0.9:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" "gnome-extra/evolution-data-server[oauth-gtk3]"
+}