summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-01-20 23:57:41 +1300
committerJoonas Niilola <juippis@gentoo.org>2021-02-01 15:22:47 +0200
commit94a3608a53bc75ea0671f22f5ef9ee8e353b6b08 (patch)
tree3f26d2568a48a86626ec3edd7a4d1b4980fcba13
parentsys-process/evisum: bump to 0.5.10 (diff)
downloadgentoo-94a3608a.tar.gz
gentoo-94a3608a.tar.bz2
gentoo-94a3608a.zip
sys-fs/compsize: bump to 1.4
ebuild changes: - use einstalldocs instead of dodoc - update PREFIX instead of sedding "/usr" to Makefile - remove append-cflags -std=gnu90 - add -Wall to debug flags Closes: https://bugs.gentoo.org/716200 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-fs/compsize/Manifest1
-rw-r--r--sys-fs/compsize/compsize-1.4.ebuild39
-rw-r--r--sys-fs/compsize/compsize-9999.ebuild12
3 files changed, 44 insertions, 8 deletions
diff --git a/sys-fs/compsize/Manifest b/sys-fs/compsize/Manifest
index 79e2201e8b0f..ddbbc7d51ef2 100644
--- a/sys-fs/compsize/Manifest
+++ b/sys-fs/compsize/Manifest
@@ -1 +1,2 @@
DIST compsize-1.3.tar.gz 14782 BLAKE2B 738ff0e2b936f5974064759914284e495c895d22d95b705e1b8fac4b3189891771b0e5be7e0eeac0883dd92f9cef276400bb7ee79840fd7db14a5269e7f78f11 SHA512 411b92651fdc3d03deccbf38f72936fee95cf80c67d6368efbc0dafacfe9793815a23ef0d02f7feadf31391e415df3d90cd19fb3acc8cce94f37cb3e4eed623d
+DIST compsize-1.4.tar.gz 15001 BLAKE2B 7e4d4a1f3ea59b23fec891c084f68ddb74838320a817767e48eb857de9678a1915d304d25b454afafec867ea6a028d99d9182087d3229ddae55d8305fe6b174c SHA512 c07081721f87d8a59e724a62a0a6d6724434292e6bb3ffb71acd7c47e21727db8f02f4df296cb6094c0e80d3cd555018e492616747ce69055d21302a6617ca54
diff --git a/sys-fs/compsize/compsize-1.4.ebuild b/sys-fs/compsize/compsize-1.4.ebuild
new file mode 100644
index 000000000000..41911740180e
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
+else
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+IUSE="debug"
+SLOT="0"
+
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+}
+
+src_configure() {
+ use debug && append-cflags -Wall -DDEBUG -g
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
+}
diff --git a/sys-fs/compsize/compsize-9999.ebuild b/sys-fs/compsize/compsize-9999.ebuild
index 3144e142c1e2..41911740180e 100644
--- a/sys-fs/compsize/compsize-9999.ebuild
+++ b/sys-fs/compsize/compsize-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,18 +26,14 @@ src_prepare() {
default
# Don't try to install a gzipped manfile during emake install
sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
- # sys-fs/compsize > 1.3 removes '/usr' from install paths in Makefile
- sed -i $'s/(PREFIX)/(PREFIX)\/usr/' Makefile || die
}
src_configure() {
- # Used in upstream Makefile, but clobbered by portage's CFLAGS
- append-cflags -Wall -std=gnu90
- use debug && append-cflags -DDEBUG -g
+ use debug && append-cflags -Wall -DDEBUG -g
default
}
src_install() {
- emake PREFIX="${D}" install
- dodoc "README.md"
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
}