summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-08-20 11:44:12 +0200
committerStephan Hartmann <sultan@gentoo.org>2022-08-20 11:44:32 +0200
commit94bc8221d9c652aebbfa16405338dd7e19cb8261 (patch)
treef6bf7e6c0886772b2060cee32cacf110edc99042
parentwww-client/chromium: Stabilize 104.0.5112.101 arm64, #865839 (diff)
downloadgentoo-94bc8221d9c652aebbfa16405338dd7e19cb8261.tar.gz
gentoo-94bc8221d9c652aebbfa16405338dd7e19cb8261.tar.bz2
gentoo-94bc8221d9c652aebbfa16405338dd7e19cb8261.zip
net-misc/croc: add 9.6.0
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
-rw-r--r--net-misc/croc/Manifest1
-rw-r--r--net-misc/croc/croc-9.6.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index bc13ffce87d9..4b74cc22e741 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -1,2 +1,3 @@
DIST croc-9.5.5.tar.gz 2868323 BLAKE2B 52fda421cca32ec2f1f45f0df8e38e44c7dbb161856f9624665816b60957f5906ec01b4bdb0efd769974d2eed6f423adf987397a2e6e064e48382286d5c602a2 SHA512 7bb4f23dc6b0f809da87d67b10cfb1530cb138a3a70c9578b35de602ddf90cd0f61c2ba643a83d990890a07de29588b1387b83ac63b8eac2a75620a221330eb8
DIST croc-9.5.6.tar.gz 2868248 BLAKE2B db9d2662ce4683767a57b88c7e06240243a93b1e0fadaa2d4ca42427df241afb5c9b290c879f18d59aa2600c8b8efc7b1716acdf1b11f57677d8d4672bd960bd SHA512 3342e0bc6e45c38653d2cca99d6e1b7b79450bdd05c77f3c073f0a4573a99a74b38da36d17950b5da49f99093dbc04c67f03816e3e831770491f0660e78b9266
+DIST croc-9.6.0.tar.gz 2858439 BLAKE2B fb1edc8a7c926894e7402892e029940be63a947ad692ea3f634f07c1c7c56ef687a5a0d6aab8c2814d09e9dc1324ba234f278525e93031ae0a2c889630dd04c1 SHA512 df0ebb71ac1e897864b5a01531a4d9fd20e1f56eb4fb11f8aed25456d6571acf5703d6415669446d239add59ec5510751358768b0ef890b6fded2ac03160d84b
diff --git a/net-misc/croc/croc-9.6.0.ebuild b/net-misc/croc/croc-9.6.0.ebuild
new file mode 100644
index 000000000000..03dce788293d
--- /dev/null
+++ b/net-misc/croc/croc-9.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+
+SRC_URI="https://github.com/schollz/croc/releases/download/v${PV}/${PN}_${PV}_src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable-network-tests-r1.patch"
+)
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -work ./...
+}