summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-05-03 07:54:14 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-05-03 07:55:18 -0500
commit94c50cdbfeb2a2394e4165c0333aeb10df85a434 (patch)
tree1bab5c30b8f0b402af74b20752d470d2d9c297fc
parentfixup (diff)
downloadgentoo-94c50cdbfeb2a2394e4165c0333aeb10df85a434.tar.gz
gentoo-94c50cdbfeb2a2394e4165c0333aeb10df85a434.tar.bz2
gentoo-94c50cdbfeb2a2394e4165c0333aeb10df85a434.zip
sys-apps/usbredir: ebuild maintenance
- update live ebuild - shorten description Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild2
-rw-r--r--sys-apps/usbredir/usbredir-0.7.ebuild4
-rw-r--r--sys-apps/usbredir/usbredir-9999.ebuild14
3 files changed, 12 insertions, 8 deletions
diff --git a/sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild b/sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild
index a5e19237bfe8..1a53fb75aff4 100644
--- a/sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild
+++ b/sys-apps/usbredir/usbredir-0.7.1_p20170503.ebuild
@@ -6,7 +6,7 @@ inherit eutils flag-o-matic
MY_PV=${PV/_p*/}
-DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
HOMEPAGE="http://spice-space.org/page/UsbRedir"
SRC_URI="http://spice-space.org/download/${PN}/${PN}-${MY_PV}.tar.bz2
https://dev.gentoo.org/~tamiko/distfiles/${P}-patches.tar.xz"
diff --git a/sys-apps/usbredir/usbredir-0.7.ebuild b/sys-apps/usbredir/usbredir-0.7.ebuild
index 84a69d774d90..eb4e001c618a 100644
--- a/sys-apps/usbredir/usbredir-0.7.ebuild
+++ b/sys-apps/usbredir/usbredir-0.7.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils flag-o-matic
-DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
HOMEPAGE="http://spice-space.org/page/UsbRedir"
SRC_URI="http://spice-space.org/download/${PN}/${P}.tar.bz2"
diff --git a/sys-apps/usbredir/usbredir-9999.ebuild b/sys-apps/usbredir/usbredir-9999.ebuild
index e2f4dc015ed3..bacd7a0726dc 100644
--- a/sys-apps/usbredir/usbredir-9999.ebuild
+++ b/sys-apps/usbredir/usbredir-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils flag-o-matic autotools git-2
+inherit eutils flag-o-matic autotools git-r3
-DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
HOMEPAGE="http://spice-space.org/page/UsbRedir"
EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/usbredir.git"
@@ -20,11 +20,15 @@ DEPEND="${RDEPEND}
DOCS="ChangeLog README* TODO *.txt"
-EGIT_BOOTSTRAP="eautoreconf"
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
# https://bugs.freedesktop.org/show_bug.cgi?id=54643
append-cflags -Wno-error
+
econf $(use_enable static-libs static)
}