summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:45:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 06:06:39 +0100
commit94d7a0c8c037ffd0eb098bea5b147f7131a396f9 (patch)
tree6b0773eaba6c35b2cf918e1956e8098a2dd5cbd9
parentdev-python/tld: Bump to 0.13 (diff)
downloadgentoo-94d7a0c8.tar.gz
gentoo-94d7a0c8.tar.bz2
gentoo-94d7a0c8.zip
dev-python/cfn-lint: Bump to 0.74.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.74.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 35fa0f6f5eaf..709d786d40cc 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -2,3 +2,4 @@ DIST cfn-lint-0.72.10.gh.tar.gz 3252485 BLAKE2B 34290170b4620f2f094d96ebb41cb9e5
DIST cfn-lint-0.72.9.gh.tar.gz 3239001 BLAKE2B 935d07e58d12a7b95bb589523a9ef49c9f508386d58384e7b391442ef02e304e583d687fce0f8faf892049525d6e621670061ab96a124229de7fc94df3e3533e SHA512 bf83e4146d4f2951e670c07a3a0bb3ab212881af9687c16244cade18bac101468c35532516731f66a80708312a9ee33bc531be9a6b7fab671bf54d596886a523
DIST cfn-lint-0.73.1.gh.tar.gz 3337094 BLAKE2B 0fd3ac1116f8d38ebc4eef04bca5a6f6970c270682941a820240180d5eaa5908a8320e4e2adb0f29fe132dd56215fb42377435099a3ccb95697cc2caaa391794 SHA512 efdc54f983f9b7200ee725a844a9d83674309c080fb62c63e02430eb81c2992c4232a42bbe34d7b7f4ecc5097403bd9d8bf55806876f83e4ba3993e62597b675
DIST cfn-lint-0.73.2.gh.tar.gz 3343513 BLAKE2B 48ec085ec1d4c6fcee57d44915b65760481cd753805de3817c63aa093480aef15c81583cfa5f61f62407002c0d82cb9f36f146afffcc6f30dc0043f4f6fa991b SHA512 f85909cefb0882d4b36c26542c9ec65af520797e25b849bdbeb2e7e18b4f1675f0ede1b7cb19c529d8d393345ed48d98cc67e7e5d752790c3d9829bd6d69c052
+DIST cfn-lint-0.74.0.gh.tar.gz 3633749 BLAKE2B 68ba32c66a6cc4ddf1260523679565e7074e159c1d63b8e408a40426e0c3e7ec60159075b8dc91bb40d2fbdb8fb5a5fd55c0f70d02c165900a64a0d032285492 SHA512 635621995b74068ec2be9fcda0b710ab975e8aea428317d254fd6e93b2602071b985a6d80c12321b8245c2569b84b6c7c46e4cacfd59f0d0e21926ad6782e2f0
diff --git a/dev-python/cfn-lint/cfn-lint-0.74.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.74.0.ebuild
new file mode 100644
index 000000000000..5d67809f6acd
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.74.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.59.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}