summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 18:54:23 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 18:54:23 -0700
commit94d8520e1d97b28f91f3e4ed3eb216d4197ab261 (patch)
tree72f153536c3c9d306facd97ccc5132805a70ec1c
parentdev-python/python-sshpubkeys: new package (diff)
downloadgentoo-94d8520e.tar.gz
gentoo-94d8520e.tar.bz2
gentoo-94d8520e.zip
dev-python/python-jose-3.1.0: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/python-jose/Manifest1
-rw-r--r--dev-python/python-jose/python-jose-3.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-jose/Manifest b/dev-python/python-jose/Manifest
index 0906e01b6a56..1c1ed1851329 100644
--- a/dev-python/python-jose/Manifest
+++ b/dev-python/python-jose/Manifest
@@ -1 +1,2 @@
DIST python-jose-3.0.1.tar.gz 86726 BLAKE2B 82ad3cd1139b367d179e965aaf0e33f3592883da6b21ecb3a91e9fe98ff05dbe358e56156a3d34366ffc0d7bfa9efbcdef67c41307d803ac16144a0c0ac3570b SHA512 a39c3aa9acc6bcc0030e4435e499581043a820c54aa1a4b67ae478cf95f96f28755b03fa4453e484932a64865a61613a1ff4afe30249216e8f392638485693d7
+DIST python-jose-3.1.0.tar.gz 101693 BLAKE2B 1ee43ac5aef673f32c3d56e492784e28939b8f74a8232a83d31381b3f978d96ab132c94527df686b52f60c2865936ce022c2cd31ea66f009a83772d1389a7d4a SHA512 c4a04bed8fc17d65cb8fc9b2cf37996edb50fa0dcdc2dedd76a97c784f8af34a9c86748ea2f9ea348955ce780035fbe3a756abc8e1eb5e9b77ad57d411622c6b
diff --git a/dev-python/python-jose/python-jose-3.1.0.ebuild b/dev-python/python-jose/python-jose-3.1.0.ebuild
new file mode 100644
index 000000000000..87dfe24d778d
--- /dev/null
+++ b/dev-python/python-jose/python-jose-3.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="A JavaScript Object Signing and Encryption (JOSE) implementation in Python"
+HOMEPAGE="https://github.com/mpdavis/python-jose https://pypi.org/project/python-jose/"
+# pypi tarball lacks unit tests
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/mpdavis/python-jose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.3.1[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's|'\''pytest-runner'\'',\?||' -i setup.py || die
+ distutils-r1_python_prepare_all
+}