summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-04-30 15:40:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-04-30 16:10:20 +0200
commit94dcd6dfff1efcc29839f69a57a81e13d8f29ea7 (patch)
treee80dc6d16a918599e6dada07d2e7a1fdfcd07c10
parentapp-metrics/collectd: add write_syslog plugin (diff)
downloadgentoo-94dcd6df.tar.gz
gentoo-94dcd6df.tar.bz2
gentoo-94dcd6df.zip
app-metrics/collectd: add procevent plugin
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--app-metrics/collectd/collectd-5.11.0.ebuild11
-rw-r--r--profiles/desc/collectd_plugins.desc1
2 files changed, 7 insertions, 5 deletions
diff --git a/app-metrics/collectd/collectd-5.11.0.ebuild b/app-metrics/collectd/collectd-5.11.0.ebuild
index f1c40831c229..0a813ac18656 100644
--- a/app-metrics/collectd/collectd-5.11.0.ebuild
+++ b/app-metrics/collectd/collectd-5.11.0.ebuild
@@ -58,11 +58,11 @@ COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
memcachec memcached memory modbus mqtt multimeter mysql netlink
network network nfs nginx notify_desktop notify_email notify_nagios
ntpd numa nut olsrd onewire openldap openvpn oracle ovs_events
- ovs_stats perl ping postgresql powerdns processes protocols python
- python redis routeros rrdcached rrdtool sensors serial sigrok slurm
- smart snmp snmp_agent statsd swap sysevent syslog table tail tail_csv
- target_notification target_replace target_scale target_set tcpconns
- teamspeak2 ted thermal threshold turbostat ubi unixsock
+ ovs_stats perl ping postgresql powerdns procevent processes protocols
+ python python redis routeros rrdcached rrdtool sensors serial sigrok
+ slurm smart snmp snmp_agent statsd swap sysevent syslog table tail
+ tail_csv target_notification target_replace target_scale target_set
+ tcpconns teamspeak2 ted thermal threshold turbostat ubi unixsock
uptime users uuid varnish virt vmem vserver wireless write_graphite
write_http write_influxdb_udp write_kafka write_log write_mongodb
write_prometheus write_redis write_sensu write_syslog write_tsdb
@@ -119,6 +119,7 @@ COMMON_DEPEND="
collectd_plugins_perl? ( dev-lang/perl:=[ithreads] )
collectd_plugins_ping? ( net-libs/liboping )
collectd_plugins_postgresql? ( dev-db/postgresql:= )
+ collectd_plugins_procevent? ( dev-libs/yajl:= )
collectd_plugins_python? ( ${PYTHON_DEPS} )
collectd_plugins_redis? ( dev-libs/hiredis:= )
collectd_plugins_routeros? ( net-libs/librouteros )
diff --git a/profiles/desc/collectd_plugins.desc b/profiles/desc/collectd_plugins.desc
index c5e26e3d3b41..804b186851c2 100644
--- a/profiles/desc/collectd_plugins.desc
+++ b/profiles/desc/collectd_plugins.desc
@@ -91,6 +91,7 @@ perl - Build the perl language binding plugin (embeds a Perl interpreter into co
ping - Build the ping input plugin (measures network latency)
postgresql - Build the postgresql input plugin (executes SQL statements against a PostgreSQL database)
powerdns - Build the powerdns input plugin (collects statistics from the PowerDNS name server or recursor via control socket)
+procevent - Build the procevent input plugin (monitors process starts/stops via netlink library)
processes - Build the processes input plugin (collects the number of processes, grouped by their state or detailed statistics about selected processes)
protocols - Build the protocols input plugin (collects information about the network protocols supported by the system)
python - Build the python language binding plugin (embeds a Python interpreter into collectd for writing plugins)