summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-27 23:20:00 +0100
committerSam James <sam@gentoo.org>2022-03-27 23:36:14 +0100
commit94f2ae3e7bef411dbfc517fc24a1a1fe880d2ab8 (patch)
tree980f52d7704c578a1b460b38e2f804225ef68a68
parentprofiles: Mark a bunch of GNOME2/GTK-2 packages deprecated (diff)
downloadgentoo-94f2ae3e7bef411dbfc517fc24a1a1fe880d2ab8.tar.gz
gentoo-94f2ae3e7bef411dbfc517fc24a1a1fe880d2ab8.tar.bz2
gentoo-94f2ae3e7bef411dbfc517fc24a1a1fe880d2ab8.zip
dev-util/strace: add 5.17
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-5.17.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index 6c34dba08db6..fd62d64d49c1 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -2,3 +2,4 @@ DIST strace-5.12.tar.xz 2009060 BLAKE2B 9a7a07e5d2d38c8b456f54d0e1d7c776066b2032
DIST strace-5.14.tar.xz 2067020 BLAKE2B 479ecf5e66e26e722d108c905130f482c411857db234ac013bf3568905c0f7b896f001ba6da2cabccd0a987c7802aebec9c6298decb691de125e8154c28e1c6f SHA512 3e147521773d900167809db9feeb148e8ba116f90dd634311941ea335eb7bd8b73ab9e641bd2dcfe899ab41c19a841e203dc771ec3000ae01452d22ecdc43c5a
DIST strace-5.15.tar.xz 2248664 BLAKE2B fff08e49552ad1208b658f91e37c540cc7315ac255aba2e69db5bfeb942114b865f1114a45663481f1ab967db45d187bdbcf70ffe80449169df0c37ff82a1a94 SHA512 67251792ad0fb7f44013c3ae5e5b757106223c9d123d349e31de7565e0f2bfdc6bbd46a9c269e58508bd288ee70f104f8e2185f2203bd91431c5c776db0d9384
DIST strace-5.16.tar.xz 2265944 BLAKE2B 0c0fb133e8642c30a8c706ba23c2d0976ff4e6662a1d07c6cd3cb70aaa980020d54220fe0baddcb70e3c3eb24bc2a8733e4b52ef4e99da5c11ed852c192a5c21 SHA512 db5993ece5600d928a42dedd2d5c8efec5b9195becb5fe6913f58f4e2f486d80f1700d63d1e67b591d4e6b13d19c4fcc0c52a4d0fa57c5a5a2ea73c4edd0f817
+DIST strace-5.17.tar.xz 2281220 BLAKE2B 27e7dc19302c58144b0a7d8de41f717760b8e3cde4ab56892045727597bbfc894bf8f137aee476548c2d16d1e9c8005f931f31a5d2f8bfc4ce5565c2aa01f1ec SHA512 1b63cf7e6e339333b9d24fa20232409192abc815f2ebe2e336ef4acc039cd06c976b3c12e9ce993491a0e6b86c26b90ceba962f580e894b1ff5ab9863bdfcc44
diff --git a/dev-util/strace/strace-5.17.ebuild b/dev-util/strace/strace-5.17.ebuild
new file mode 100644
index 000000000000..a0531b88dede
--- /dev/null
+++ b/dev-util/strace/strace-5.17.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strace/strace.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="https://strace.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl selinux static unwind elfutils"
+REQUIRED_USE="?? ( unwind elfutils )"
+
+BDEPEND="virtual/pkgconfig"
+LIB_DEPEND="
+ unwind? ( sys-libs/libunwind[static-libs(+)] )
+ elfutils? ( dev-libs/elfutils[static-libs(+)] )
+ selinux? ( sys-libs/libselinux[static-libs(+)] )
+"
+# strace only uses the header from libaio to decode structs
+DEPEND="
+ static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.11-static.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if [[ ! -e configure ]] ; then
+ # git generation
+ sed /autoreconf/d -i bootstrap || die
+ ./bootstrap || die
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ # Stub out the -k test since it's known to be flaky. bug #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ # Set up the default build settings, and then use the names strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
+ filter-lfs-flags # configure handles this sanely
+
+ export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
+
+ local myeconfargs=(
+ --disable-gcc-Werror
+
+ # Don't require mpers support on non-multilib systems. #649560
+ --enable-mpers=check
+
+ $(use_enable static)
+ $(use_with unwind libunwind)
+ $(use_with elfutils libdw)
+ $(use_with selinux libselinux)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has usersandbox ${FEATURES} ; then
+ # bug #643044
+ ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..."
+ return 0
+ fi
+
+ default
+}
+
+src_install() {
+ default
+
+ if use perl ; then
+ exeinto /usr/bin
+ doexe src/strace-graph
+ fi
+ dodoc CREDITS
+}