summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-21 01:27:07 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-21 01:34:22 -0500
commit94f677f3d2a7db54368a9c0e777b5787747525a8 (patch)
tree71b1e72ee7e44bd010a980ce4709d6d2d21bc6ae
parentsys-apps/syd: add 3.3.3, drop 3.3.1 (diff)
downloadgentoo-94f677f3d2a7db54368a9c0e777b5787747525a8.tar.gz
gentoo-94f677f3d2a7db54368a9c0e777b5787747525a8.tar.bz2
gentoo-94f677f3d2a7db54368a9c0e777b5787747525a8.zip
x11-terms/kitty: use go-env.eclass
Still not fond of go-module.eclass in mixed projects, but this one does a straight forward job and no reason not to use it. May have been interesting if it handled GOFLAGS too, but ah well. tc-export CC is redundant but it's needed by kitty regardless of go, so keep it in a separate block to avoid confusion/removal. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/kitty-0.31.0.ebuild7
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/x11-terms/kitty/kitty-0.31.0.ebuild b/x11-terms/kitty/kitty-0.31.0.ebuild
index 9090e9ba7a22..40e4c5d20049 100644
--- a/x11-terms/kitty/kitty-0.31.0.ebuild
+++ b/x11-terms/kitty/kitty-0.31.0.ebuild
@@ -4,7 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -124,9 +125,11 @@ src_prepare() {
src_compile() {
tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local conf=(
--disable-link-time-optimization
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 9090e9ba7a22..40e4c5d20049 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -124,9 +125,11 @@ src_prepare() {
src_compile() {
tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local conf=(
--disable-link-time-optimization